Bug 347181 - Port httpd to use NSS library for cryptography
Summary: Port httpd to use NSS library for cryptography
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: CryptoConsolidation
TreeView+ depends on / blocked
 
Reported: 2007-10-23 10:19 UTC by Peter Vrabec
Modified: 2011-11-10 01:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-10 01:31:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Vrabec 2007-10-23 10:19:01 UTC
httpd should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.

Comment 1 John Poelstra 2008-08-12 04:06:33 UTC
triaged

Comment 2 Jan Kaluža 2011-10-20 07:55:49 UTC
Isn't it already done according to http://fedoraproject.org/wiki/FedoraCryptoConsolidation ? mod_nss exists already for some years.

Comment 3 Tomas Mraz 2011-10-20 08:11:54 UTC
Yes.

Comment 4 Joe Orton 2011-10-20 14:04:54 UTC
httpd remains using OpenSSL, though, and will do so since we have no intention of dropping mod_ssl.

Comment 5 Joe Orton 2011-11-10 01:31:48 UTC
It does seem pointless keeping this bug open.  Remaining uses of OpenSSL in httpd are not going away.


Note You need to log in before you can comment on or make changes to this bug.