Bug 347221 - Port iscsi-initiator-utils to use NSS library for cryptography
Port iscsi-initiator-utils to use NSS library for cryptography
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: iscsi-initiator-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Leech
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:19 EDT by Peter Vrabec
Modified: 2014-10-02 17:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-02 17:15:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:19:10 EDT
iscsi-initiator-utils should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Mike Christie 2007-10-23 14:51:53 EDT
Is iscsi-initiator-utils on the needs conversion list because its spec has the

BuildRequires: openssl-devel

line?

I think iscsi-initiator-utils probably does not need that line. In the Makefile,
we do not seem to be building against any libraries that look crypto related,
and it looks like it implements its own md5 sha1 code.

Is this bugzilla for iscsi-initiator-utils to not do its won md5 and sha1 code
and instead use the NSS lib?

Thanks.
Comment 2 Tomas Mraz 2007-10-23 15:15:01 EDT
If the md5 and sha1 is used for security relevant operations then yes, the
built-in source should be replaced with calls to NSS lib.

Note You need to log in before you can comment on or make changes to this bug.