Bug 34731 - generic.img (boot disk) unusable
Summary: generic.img (boot disk) unusable
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: alpha
OS: Linux
medium
high
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-04 14:36 UTC by Chris Kloiber
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-21 05:45:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Kloiber 2001-04-04 14:36:44 UTC
Can't boot floppy created from generic.img from qa0404.1. Last working
generic.img was in qa0320.1

Error is:

ext2_blkno: block number too large: xxxxx

Error repeats and xxxxx increments until it hits a PYXIS machine check and
machine "reboots" itself to the milo prompt.

My hardware is AlphaPC 164SX, 533Mhz, 128M Ram, IDE hard drives..

Reproducable always.

The good news is if I use the generic image from qa0320 and copy iso images
to one of the partitions I can do a hard drive install (can't do net
because of the need for network modules)

Comment 1 Phil Copeland 2001-04-04 17:58:51 UTC
Umm lets see,...

Thats an aboot message (not kernel)

	[root@alpha linux-2.4]# find . -type f  | xargs -n1 grep ext2_blkno
	[root@alpha linux-2.4]# 

	[root@alpha aboot-0.7a]# find . -type f  | xargs -n1 grep -l ext2_blkno
	./fs/ext2.c
	./tools/e2lib.c
	./tools/e2lib.h

What might be happening here is that the aboot is incapable of reading the MSDOS
partition and is getting very confused by it.

I don't have a machine to hand to try that theory though. (well I have my own
personal machine however,.. I'm not about to nuke it!)

Phil
=--=

Comment 2 Phil Copeland 2001-04-21 05:44:02 UTC
Umm small question for you,.. does your boot kernel reside on a seperat
partition or on one large disk?

if it's one large partition whats probably happening is that the kernel is
residing on a part of the disk that aboot can't reach, much the same as the
problems with old versions of lilo in the i386 universe

Does this help you at all?

Phil
=--=

Comment 3 Phil Copeland 2001-06-04 19:30:46 UTC
No reply, record closed



Note You need to log in before you can comment on or make changes to this bug.