Bug 34739 - checkpc has wrong perms for "filter"
checkpc has wrong perms for "filter"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 13:08 EDT by j. alan eldridge
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-04 13:08:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description j. alan eldridge 2001-04-04 13:08:47 EDT
This change occurred with the 3.7.4 RPM used by both wolverine and rawhide.
There's a program called checkpc which, among other things, forces 
permissions for certain files back to values it "knows". 

Well, for /var/spool/lpd/{printer}/filter, a symlink 
to /usr/libexec/master-filter, checkpc wants the perms for this file to be 
0600. Unfortunately, lpd wants (*needs*) the permissions to be 700, since 
it needs to execute that file.

So, when you start lpd, checkpc bitches about perms on .../filter being 
711, not 600, and sets them to 600. Then lpd comes along and bitches that 
the .../filter does not have execute permission.

In this little battle of wills, lpd is right, since if /usr/libexec/master-
filter doesn't have execute perms, nothing gets spooled or printed.
Comment 1 Preston Brown 2001-04-04 16:24:23 EDT
this has been fixed in at least LPRng-3.7.4-22 and later.

Note You need to log in before you can comment on or make changes to this bug.