Bug 3474 - PUMP and buggy DHCP servers that don't return server identification option
PUMP and buggy DHCP servers that don't return server identification option
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-15 04:29 EDT by breed
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-31 18:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description breed 1999-06-15 04:29:28 EDT
If PUMP gets an OFFER or ACK back without a server id option
it bags everything.  While RFC 2131 is clear that OFFER and
ACK must have the server id, some simple DHCP servers (such
as those found in Ascend boxes) do not return that option.

A simple workaround is to use the broadcast address if the
server id isn't present.
Comment 1 breed 1999-06-15 12:12:59 EDT
There is a patch that fixes this and other problems in pump (as well
as reporting errors in syslog) at
http://www.cse.ucsc.edu/~breed/pump.patch.
Comment 2 Erik Troan 1999-06-22 15:29:59 EDT
Done in CVS (we'll have a package soon). (thanks for the patch)
Comment 3 Bill Nottingham 1999-08-31 18:34:59 EDT
This should be fixed in the latest errata release.

Note You need to log in before you can comment on or make changes to this bug.