Bug 34744 - gmc in RH7.0 does not recognize mime-type changes
gmc in RH7.0 does not recognize mime-type changes
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gmc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 13:39 EDT by Brett Gladman
Modified: 2013-04-02 00:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 08:42:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brett Gladman 2001-04-04 13:39:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (X11; I; Linux 2.2.12-32 i686)


I have 3 different RedHat 7.0 installations, all of which exhibit this bug,
and none of my
older 6.2 installations did.
In my previous RH6.2 installations I modified mime-types often to change
icons and
actions associated with open/view/etc, which worked very well. 
Under RH7.0 the mime types get changed (either via the Edit Mime Types in
the
gmc Commands menu, or via the gnome control center, which is probably the
same
thing as I imagine gmc just calls the Control Center), and one can see that
the requested changes have been emplaced in .gnome/mime-info/users.keys but
then
gmc appears NOT to be looking at this file. See example below.

Reproducible: Always
Steps to Reproduce:
1.  open gmc
2.  In Commands menu select Edit mime types.
3.  Find application/x-dvi,  for example (it doesn't matter, no mime types
work)
4.  Change icon by clicking browse, going up one level, and taking
gnome-tigert.png
5.  Hit `Try' or `OK'
6.  cat .gnome/mime-info/users.keys to see 
application/x-dvi:
	[en_US]icon-filename=/usr/share/pixmaps/./gnome-tigert.png
    as it should be, but if you look at a .dvi file in gmc or just re-open
the mime type
you will see that the icon information has not been stored


Actual Results:  The above was the easiest example, but lots of other
associations do not get
registered.  SOME do. For example, I can associate the Open action of
application/x-tex
with 
rxvt -e latex %f
successfully, but cannot change the icon for example.  In fact, changing
the icon
results in the default TeX icon changing permanently to come bland generic
icon
and there is no way to change it again. Nor can I change edit to
gvim %f
for example. Or even rxvt -e vi %f

Expected Results:  Mime types should be read back once changed.

I noted that the most recent version of gmc is supposed to now be
gnome-compliant
and perhaps the new problems are associated with that adaptation.
However, I tried loading unistalling the most recent gmc and installing via
RPM the
version of gmc on my RH6.2 laptop (gmc-4.5.39-0.91)  but had the same
problem,
so it may be deeper.
I tried upgrading my gmc on the RH7.0 system (which was 4.5.51-18) to the
slightly
newer 4.5.52-2 from rpmfind, but that also does not help.
Comment 1 Jonathan Blandford 2001-07-30 14:13:51 EDT
gmc is deprecated in favor of Nautilus.

Note You need to log in before you can comment on or make changes to this bug.