Bug 34745 - ThinkPad T20/T21 fails to sleep with power plugged in
ThinkPad T20/T21 fails to sleep with power plugged in
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 13:57 EDT by Scott Russell
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 14:32:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Russell 2001-04-04 13:57:54 EDT
I have an IBM ThinkPad T20/T21 that fails to sleep if plugged in when fn+f4
is pressed. The screen blanks as if it's going to sleep, beeps, then comes
back on. The sleep LED never lights. Other times the screen blanks and
stays blank but again the sleep LED never lights.

If power is unplugged or the thinkpad is removed from the dock then sleep
works. (The sleep LED comes on)

The problem with this is that in order to warm swap anything in the
ultrabay you need to put the thinkpad to sleep before ejecting / inserting
the new component.(Example: changing from cdrom to floppy.)
Comment 1 Scott Russell 2001-04-04 13:58:33 EDT
Dang it. Forgot to say this is RC2 qa0401, fresh install.
Comment 2 Bernhard Rosenkraenzer 2001-04-15 17:40:57 EDT
Since the APM scripts don't check any of this, this is either a kernel problem 
(VERY unlikely) or a BIOS problem (VERY likely, almost everything in our apm 
scripts is needed only because most APM BIOSes are ultimately broken).

Comment 3 Scott Russell 2001-04-15 20:19:48 EDT
IBM's ThinkPad BIOS team would like to work with Red Hat to resolve this issue. 
AT initial inquaries the BIOS team is not aware of any APM bugs which would 
cause this problem. Requesting Red Hat's assistance to identified the problem 
(kernel or BIOS?) and fix. 

Please provide a contact in the kernel development team of Red Hat that we can 
work with. If there is another method that should be followed to make Red Hat 
7.1 work on IBM T20/T21 systems please let us know.
Comment 4 Scott Russell 2001-05-23 00:10:25 EDT
Using the provided test kernel I still have this problem. If AC power is
connected the thinkpad will not go into sleep state, even using allow_init.

I did discover new info. I CAN make the thinkpad sleep by pressing fn+f4 IF no
pcmcia cards are in the sockets. If a card is in socket 0 or 1 then with the AC
connected the thinkpad never sleeps. If I use cardctrl to eject all cards then
press fn+f4 while AC power is connected the thinkpad does sleep as expected.

Comment 5 Scott Russell 2002-04-03 14:32:52 EST
This should be closed since skipjack is out. I'll retest there and open up new 
bugs as needed to cover the new release.

Note You need to log in before you can comment on or make changes to this bug.