Bug 34771 - ghost SCSI/USB modules reading errating kernel memory
ghost SCSI/USB modules reading errating kernel memory
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 17:34 EDT by Arenas Belon, Carlo Marcelo
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-03 14:07:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arenas Belon, Carlo Marcelo 2001-04-04 17:34:31 EDT
when autoplug is executed to load a module on the kernel because of a
hardware event (a device is connected), it doesn't check back to unload de
module when the device is disconected.

as the usb device is no longer connected, quering information such
(cdrecord -scanbus), returns errating messages from an already existing
scsi device that no longer belongs to a device.

this has been tested on qa0328 and kernel 2.4.2-0.1.40.
Comment 1 Pete Zaitcev 2002-06-03 14:07:09 EDT
I am afraid this is WONTFIX material.
We found that doing the "rmmod -a from cron" trick is
very harmful (it removes usb-uhci, for instance).
Upstream community says the same.

It should be possible for sd to figure that the device
is offline (by check condition status from usb-storage).
If it does not work, I can consider an RFE.

Note You need to log in before you can comment on or make changes to this bug.