Bug 34775 - RFE: vgchange -a n should be called on /etc/init.d/halt when lvm-module is loaded
RFE: vgchange -a n should be called on /etc/init.d/halt when lvm-module is lo...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 19:24 EDT by Arenas Belon, Carlo Marcelo
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 17:17:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to /etc/init.d/halt for shuting down the LVM system on halt. (520 bytes, patch)
2001-04-04 19:29 EDT, Arenas Belon, Carlo Marcelo
no flags Details | Diff
FIXED patch, use this (475 bytes, patch)
2001-04-04 22:29 EDT, Arenas Belon, Carlo Marcelo
no flags Details | Diff
patch to initscripts-5.83 (RH7.1 gold) (476 bytes, patch)
2001-05-03 07:55 EDT, Arenas Belon, Carlo Marcelo
no flags Details | Diff

  None (edit)
Description Arenas Belon, Carlo Marcelo 2001-04-04 19:24:44 EDT
on rc.sysinit the lvm-mod is started but there is no corresponding stop
script.

as explained on lvm documentation, a:"vgchange -a n" call should be placed
on the shutdown script after dismounting all filesystems.
Comment 1 Arenas Belon, Carlo Marcelo 2001-04-04 19:29:56 EDT
Created attachment 14665 [details]
patch to /etc/init.d/halt for shuting down the LVM system on halt.
Comment 2 Arenas Belon, Carlo Marcelo 2001-04-04 21:25:45 EDT
ok, here i come again.. with a new and TESTED patch that really works, no more
check forced on /usr after all.
Comment 3 Arenas Belon, Carlo Marcelo 2001-04-04 22:29:05 EDT
Created attachment 14683 [details]
FIXED patch, use this
Comment 4 Arenas Belon, Carlo Marcelo 2001-05-03 07:54:41 EDT
updated patch for RH7.1 gold (just a change on the directory name anyway).

calling vgchange -a n on halt is not really needed now as no metadata is saved
on the vg, but this could change soon and this is documented as a need for lvm
installations
Comment 5 Arenas Belon, Carlo Marcelo 2001-05-03 07:55:56 EDT
Created attachment 17206 [details]
patch to initscripts-5.83 (RH7.1 gold)
Comment 6 Bill Nottingham 2003-01-13 17:17:59 EST
The kernel people say that this is not needed.
Comment 7 Arenas Belon, Carlo Marcelo 2003-01-13 18:57:02 EST
it is not needed (that is why it was filled as an enhancement with low 
priority), but as you can read on LVM/{%version}/INSTALL (point 9) it is 
required as part of the LVM installation.

it does nothing when called because once you deactivate an LVM volume the only 
resource that could be freed is the LVM module and no data gets saved, but this 
could change on the future.

this patch is not recommended on systems that have the root filesystem on LVM 
though

Note You need to log in before you can comment on or make changes to this bug.