This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 347761 - Port ntp to use NSS library for cryptography
Port ntp to use NSS library for cryptography
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:21 EDT by Peter Vrabec
Modified: 2014-08-25 10:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-25 10:43:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Network Time Protocol 2644 None None None Never

  None (edit)
Description Peter Vrabec 2007-10-23 06:21:18 EDT
ntp should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Bob Lord 2008-08-27 16:56:07 EDT
What cryptographic operations does NTP use?
Comment 2 Miroslav Lichvar 2008-08-28 07:26:10 EDT
From openssl are used functions dealing with certificates, encrypting, decrypting, signing and verification.

An overview of NTP cryptography is here:
http://www.ntp.org/ntpfaq/NTP-s-algo-crypt.htm
Comment 3 Miroslav Lichvar 2014-08-25 10:43:32 EDT
I think it's time to close this bug, it looks like the crypto consolidation effort has stopped long time ago and porting ntpd to NSS won't be easy.

Note You need to log in before you can comment on or make changes to this bug.