This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 347821 - Port openmpi to use NSS library for cryptography
Port openmpi to use NSS library for cryptography
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openmpi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:21 EDT by Peter Vrabec
Modified: 2012-01-20 11:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-20 11:06:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:21:32 EDT
openmpi should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Doug Ledford 2009-03-19 15:13:08 EDT
Jay is helping out with Open MPI issues, so added him to the Cc list.
Comment 2 Orion Poplawski 2011-11-16 19:21:00 EST
I don't think openmpi uses openssl.  Does it use some other crypto library?
Comment 3 Doug Ledford 2011-11-17 14:10:00 EST
I think it was flagged because it has some internal CRC or MD5 hash implementation or something like that.  I don't think it's a heavy user of crypto, but there was *something* in there that flagged it on an automated run.
Comment 4 Doug Ledford 2012-01-20 11:06:06 EST
I can't find any relevant crypto to convert to the NSS library.  Closing this out.

Note You need to log in before you can comment on or make changes to this bug.