Bug 348131 - Port rpm to use NSS library for cryptography
Port rpm to use NSS library for cryptography
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:22 EDT by Peter Vrabec
Modified: 2008-08-08 04:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 03:17:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against 4.2.2 branch (55.25 KB, patch)
2007-11-01 07:03 EDT, Tomas Mraz
no flags Details | Diff
Patch against trunk (50.96 KB, patch)
2007-11-01 14:46 EDT, Tomas Mraz
no flags Details | Diff

  None (edit)
Description Peter Vrabec 2007-10-23 06:22:42 EDT
rpm should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Tomas Mraz 2007-10-23 07:37:37 EDT
I'm working on that just now.
Comment 2 Tomas Mraz 2007-11-01 07:03:26 EDT
Created attachment 245451 [details]
Patch against 4.2.2 branch
Comment 3 Tomas Mraz 2007-11-01 14:46:56 EDT
Created attachment 245941 [details]
Patch against trunk
Comment 4 Panu Matilainen 2007-11-12 03:17:14 EST
The 4.4.2 patch just went into rawhide, that ought to shake out any initial
issues... It's also applied in upstream HEAD.

Note You need to log in before you can comment on or make changes to this bug.