Bug 34815 - /sbin/rarp is missing from net-tools
Summary: /sbin/rarp is missing from net-tools
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-tools   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-05 04:45 UTC by Nils Philippsen
Modified: 2007-03-27 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 05:12:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils Philippsen 2001-04-05 04:45:53 UTC
As the subject says:

nils@cognac:~> rpm -ql net-tools | grep rarp
/usr/share/man/de_DE/man8/rarp.8.gz
/usr/share/man/fr_FR/man8/rarp.8.gz
/usr/share/man/pt_BR/man8/rarp.8.gz
nils@cognac:~> rpm -q net-tools
net-tools-1.57-5

On another machine (roughly RHL 7) this is:

[nils@cassis nils]$ rpm -ql net-tools|grep rarp
/sbin/rarp
/usr/share/man/de_DE/man8/rarp.8.gz
/usr/share/man/fr_FR/man8/rarp.8.gz
/usr/share/man/man8/rarp.8.gz
/usr/share/man/pt_BR/man8/rarp.8.gz
[nils@cassis nils]$ rpm -q net-tools
net-tools-1.56-2

This is only the case with this latest version of net-tools, otherwise
tripwire would have complained earlier.

Comment 1 Jeremy Katz 2001-04-05 05:12:36 UTC
IIRC, this is because rarp from net-tools doesn't work with 2.4 since the kernel
bits of rarp support were removed (it can all basically be done with userspace).
 The changelog for the net-tools package backs this up:

* Mon Apr 02 2001 Preston Brown <pbrown@redhat.com>
- don't use this version of rarp, doesn't work with our 2.4.

In fact, the userspace package is even there... take a look at the rarpd package.

Comment 2 Preston Brown 2001-04-06 19:17:35 UTC
you don't need a userland rarp tool anymore.  check out rarpd.



Note You need to log in before you can comment on or make changes to this bug.