Bug 348181 - Port samba to use NSS library for cryptography
Port samba to use NSS library for cryptography
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:22 EDT by Peter Vrabec
Modified: 2017-01-05 11:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-05 11:01:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:22:53 EDT
samba should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Andrew Bartlett 2008-08-29 00:13:14 EDT
Perhaps a more serious review (rather than mass-filing) should be conducted to see if doing so would have any benefit, and to propose a course of action that would allow this to occur?
Comment 2 Fedora Admin XMLRPC Client 2010-10-08 10:42:42 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Nico Kadel-Garcia 2013-03-05 08:20:50 EST
It's been more than 5 years on this: is NSS even compatible with samba-4.0.3?
Comment 4 Dmitri Pal 2013-03-09 18:02:23 EST
The problem is that NSS does not implement the hashes that Samba needs from compatibility point of view. Samba can't live without them while NSS would not implement them because they are insecure. I suggest closing it as WONTFIX.
Comment 5 Nikos Mavrogiannopoulos 2017-01-05 11:01:19 EST
This is no longer on-going effort (see tracker bug).

Note You need to log in before you can comment on or make changes to this bug.