Bug 34832 - up2date and rpm.
up2date and rpm.
Status: CLOSED DUPLICATE of bug 32301
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Depends On:
  Show dependency treegraph
Reported: 2001-04-05 03:08 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-05 12:38:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-05 03:08:45 EDT
after installing the new rpm (rpm-4.0.2-6x, up2date stopped working properly,
even though i have already updated all the ucd-* files.
the error messages are as follows:
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/librpm.so.0: undefined symbol: fdio
Comment 1 Need Real Name 2001-04-05 03:18:57 EDT
the linux version indicated in the header was incorrect,
the correct version is linux 6.2.
Comment 2 Adrian Likins 2001-04-05 12:18:49 EDT
You need to update the rpm-python module as well
Comment 3 Tom Neuhauser 2001-04-05 12:26:46 EDT
[root@netflow RPM]# up2date
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: undefined symbol: rpmSetVerbosity
[root@netflow RPM]# 
Comment 4 Tom Neuhauser 2001-04-05 12:38:06 EDT
With reference to my comment previously added:

This is related to RedHat 7  and up2date-2.1.7-1.i386.rpm

I see now that Bugzilla Bug 34832 was originally reported for a different
version of up2date

I wanted to add this comment to clarify.  I will create a new Bug report aimed
at 2.1.7-1
Comment 5 Preston Brown 2001-04-07 11:45:03 EDT

*** This bug has been marked as a duplicate of 32301 ***

Note You need to log in before you can comment on or make changes to this bug.