Bug 348501 - Port xen to use NSS library for cryptography
Port xen to use NSS library for cryptography
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 348661
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:24 EDT by Peter Vrabec
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 10:42:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:24:14 EDT
xen should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Daniel Berrange 2007-10-23 07:55:39 EDT
Is there a Python binding for NSS ? Without one this bug can't be addressed.
Comment 2 Daniel Berrange 2007-10-23 10:42:05 EDT
Having considered this ticket. XenD only uses SSL for the XenAPI service. We
don't use this in Fedora, since libvirt provides the management service. So I've
no interest in wasting time porting XenAPI.  The Xen device model uses QEMU
which has SSL. We are trying to get Xen to use upstream QEMU codebase rather
than its own private fork. Porting Xen's QEMU to NSS will just make it an even
worse fork compared to upstream QEMU which is not a sustainable approach.

Note You need to log in before you can comment on or make changes to this bug.