Bug 348631 - [tr_TR] gtk errors from gtkbuilder
[tr_TR] gtk errors from gtkbuilder
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 06:58 EDT by Sertaç Ö. Yıldız
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 09:17:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 488918 None None None Never

  None (edit)
Description Sertaç Ö. Yıldız 2007-10-23 06:58:56 EDT
Gtk applications that use GtkBuilder (like totem, bug-buddy etc.) refuse to
start in turkish locale.

Fixed on gtk+ svn:
http://svn.gnome.org/viewvc/gtk%2B/trunk/gtk/gtkbuilder.c?r1=18820&r2=18939&view=patch

Version-Release number of selected component (if applicable):
gtk2-2.12.1-2.fc8
Comment 1 Matthias Clasen 2007-10-24 23:26:43 EDT
I need reproduction details here, please.

LANG=tr_TR totem 

works just fine for me
Comment 2 Sertaç Ö. Yıldız 2007-10-25 04:41:54 EDT
original bug report is here:
http://bugzilla.gnome.org/show_bug.cgi?id=488918
Comment 3 Matthias Clasen 2007-10-25 06:41:05 EDT
That still doesn't explain why LANG=tr_TR totem works for me, while you say that
totem refuses to start in the turkish locale. 
Comment 4 Sertaç Ö. Yıldız 2007-10-25 07:22:03 EDT
I guess i had to say tr_TR.UTF-8 instead of just tr_TR.

Screen is filled with Gtk-ERRORs here for "LANG=tr_TR.UTF-8 totem".
Comment 5 Sertaç Ö. Yıldız 2007-10-25 07:26:06 EDT
And I know that still doesn't explain why bug-buddy doesn't start with
LANG=tr_TR while totem does. :)

But the patch above fixes the problem.
Comment 6 Matthias Clasen 2007-10-25 08:47:27 EDT
OK, I reproduced it now by running the whole session in tr_TR
Comment 7 Matthias Clasen 2007-10-25 09:17:48 EDT
Fixed in gtk2-2.12.1-5.fc8.

Note You need to log in before you can comment on or make changes to this bug.