Bug 3487 - rc.sysinit script bug
rc.sysinit script bug
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-15 16:55 EDT by pkinz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-17 17:30:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pkinz 1999-06-15 16:55:39 EDT
I was looking at why Linux says "can't find module st"
on the way up.
Turns out that the st.o (scsi tape) module is missing from
/lib/modules/2.2.5-15/scsi area so I copied it there.

Also, the /lib/modules/default link is not there because
of the bug in rc.sysinit so if you look for the
lines starting with:
       mtag=
and    mver=

It's trying to set up the 'default' link. But those 2 lines
need back-quotes ( ` ) after the equal sign and at the
end of the line to turn the resulting line into a string.
When I added that, I got the 'default' link and the error
on bringup didn't happen.

Funny think is that it still ran the scsi tape OK tho.
Comment 1 Bill Nottingham 1999-06-15 17:05:59 EDT
Actually, st is probably compiled into the kernel. ;)

The initscripts /lib/modules determination logic has
been fixed in the latest version of the initscripts, available
in Raw Hide.
Comment 2 pkinz 1999-06-16 13:20:59 EDT
What's "Raw Hide"? How do I get to it?
Comment 3 Bill Nottingham 1999-06-16 15:30:59 EDT
Raw Hide is the Red Hat rolling release program. It's a weekly
snapshot of our development tree. You can get stuff from it at
ftp://rawhide.redhat.com/ ; the files you'd be looking for would
be in the i386/RedHat/RPMS directory.

Note You need to log in before you can comment on or make changes to this bug.