Bug 34874 - Installer CD drive read incpability, and more probs
Installer CD drive read incpability, and more probs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-05 07:28 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 14:23:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-05 07:28:03 EDT
Hi,

   This a repeated problem (across two 7.1 releases)
   Actaully several problems.  I don't expect you
   to directly solve it.  I also don't need help.

   The redhat installed has _allot_ of problems.
   
   rh 7.1 (and respin) i386 from iso
      install target: P200, Intel E/V motherboard,...

   (note that the graphical install from a bootable CD 
    gave me no problems - were talking about the text
    install one gets with a boot from floppy due to
    bios limitations)

   A while back I installed rh 7.1 (not respin)

   I had many problems and the support blamed it
   on a faulty download (I still have these
   reports archived).  Funny - other bugzilla
   reports showed problems similar to mine.

   7.1 was _impossible_ for me to install -- even
   though SCO 7.1, Win95/98, Solaris 8i, Slackware
   4.1 and 7.1 all had no problems.

   But now this is the [third] time I've installed
   rh 7.1 re and, while it is _possible_ to install
   it has been a complete pain in the neck and
   required me to switch CD drives and do a minimal
   install (1 CD only) to make it happen.

-> It MUST be a REDHAT PROBLEM.  It IS the installer.

HEREITIS (were talking several install on the same
unhappy box with both 7.1 and later two separate 
downloads of 7.1 re):

       1) Mitsumi CD drives (and others) do not
       allways reach extrema of any disk: a
       installer script writer should know that.
       ==> this means the iso shouldn't be "full"

       1a) I replaced the "old" drive with a new one.
       (which, by the way, works fine with the
        graphical install)

       1b) I got the CVS for installer only to find that
        it is unworkable unless your already installed!
        (the CVS doesn't like Slackware or Windows).
        I'm too used to those old fashion unix scripts
        that you can do something with in due time!

       2) the install continues with new CD drive

          a) if any read error occurs - which is
          common on any physical device - the
          script just gives up!  *&)#$ often at
          the end of the install )(&@#

          b) using the "back" button often causes
          install failures

          c) the installer often goes all the way
          to the end of the install - then quits
          HOWEVER -- the system _STILL_ isn't bootable
--> -->   It should make a stable base system first
          before spending an hour installing RPMs!!

--> -->   d) the installer either writes to install floppy
--> -->   or reads deleted partitions

          If one has a bad install, deletes partitions
          and hard-boots, the installed ignores the
          install CD and reports a corrupted HD section,
          for God knows what reason.

          The fix that worked for me in three separate cases
          was creating a fresh boot floppy and moving the
          write protect tab.  For some reason this prevented
          furure occurances.

d) Is really BAD from a design point of view to write to
an install floppy.

          c) lilo ignores the fact that LBA is OEM version
          dependant and is a per-partition matter (note that
          LBA written data is a non-convertible format).
          So a lack of LBA on a partition not using LBA causes 
          kernel panic upon booting.
             ===> loadlin is far more stable across varied 
             installations and has a an excellent track record:

          d) installer changes active partition before
          installing any base system OR lilo; if the install
          fails anywhere, the system is left un-bootable.

          e) installer doesn't warn that writing on the MBR
          can permanently alter other OSs when they are next
          booted; in some cases causing permanent failure.

          f) installer doesn't say what "Server" and 
          "Workstation" are.  When one selects one hoping to
          find out more, the main rpm install process
          unexpectedly begins; and their is no turning back

          g) the installer has "mount" problems which causes
          it to exit if it gets "confused" when a disk has
          already been mounted (or for some reason isn't yet
          mounted).  This was a big problem when I actaully 
          got to the point of running the installer from an
          HD partition (due to CD paranoia) which I had found
          a redht faq on how to do.

All three times the disk files seemed to be in perfect order.
I still haven't found one RPM with an error in it.
My two CD drives work like any two CD drives.  Both real IDE
interfaced requiring no drivers.

The first time I pleaded that linux had a great stake in
its reliablity claim and it should be preserved.  

The support person practically made fun of me and said it was all wet and
just had a bad CD and that the egg was all over me.  I had already
downloaded the respins iso; so I couldn't verify anything.

Shortly after I installed respin after much effort.  I soon decided
to toss the disks and stick with Slackware for a bit

Yesterday, a year later, was my third attempt.  Again a pain.

Three failures with redhat 7.1 and 3-6 other systems with no
problem are no co-incidence (6, if we count by version).

I'll say it again, with pride:

Allot of linux people put in painstaking effort into reliability:
a distributor should at least provide a installer capable of unix
level reliability -- its the most critical component.

I've used linux on and off since the 91? or 92? 720k 2 floppy-only
release and installed on far worse fares than this:
       Intel P200 on Intel EV 
         (with 32MB Intel suggested HCL memory)
         (with cache meeting Intel HCL, I remember)
       Western Digital 2G HD
       Steal V3200 video card
       3COM ISA network card, no sound card
       new 40x CD-ROM drive that reads the worst of writables
          (and aMitsume 4x, which can read most writable CDs
           and still rocks for heavy load seek/set access time)

   All good stuff.  A very expensive machine at the time.

Note I don't like writing this kind of mail.  Especially as RedHat is
such an excellent system otherwise withstanding the foresaid.  I espcially
like RPM and can't see why other distributors refuse to be redhat-rpm
compatible.

Thanks,
    John D. Hendrickson

PS

I can't beleive RedHat would release something with that many
problems.  I can only imagine that certain people we "assured" such
things were done and that most problems surfaced due to "binary
pager problems with corrupt RPMs".

That's fully of it.  The text installer does not work because it is
poorly planned and done.
Comment 1 Brent Fox 2001-04-11 14:23:13 EDT
First of all, I assume you mean Red Hat Linux 7.0...not 7.1.  As of today, Red
Hat Linux 7.0 is our latest official realease.  Having said that, some of your
points are perfectly valid.

The class of installation (Workstation, Server, etc.) could be more clear
(although it is explained to some degree in the online help in the installer.)
However, once you select a method and go to the next screen, the installation of
the RPMs does not start...the packages aren't installed until almost the very
end of the install while the installation method selection takes place very
early (the fourth or fifth screen).  Furthermore, it is possible to back up and
choose another installation method.  Just keep pressing back.

You are right about LILO.  It is not perfect.  It can't do certain things like
booting off a RAID 5 partition.  However, other operating systems (such as MS
Windows NT, 2000, etc.) will write over your master boot record too.  They don't
even give you the choice.  With the Red Hat installer, you have the option of
installing LILO to the MBR, first sector of the boot partition, or even not at all.

But on the whole, you are correct.  Our installer isn't flawless, but that's why
we have bugzilla...it helps track down defects in the product and it really
helps improve stability and reliability as time goes by.

Note You need to log in before you can comment on or make changes to this bug.