Bug 348741 - Bash Version Inconsistencies
Bash Version Inconsistencies
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bash (Show other bugs)
4.5
All Linux
low Severity high
: ---
: ---
Assigned To: Tomas Janousek
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 09:37 EDT by Chris Ward
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 11:15:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ward 2007-10-23 09:37:38 EDT
Description of problem:
Perhaps it's my misunderstanding, but it seems bash versions are a bit
inconsistent (or just wrong).

RHEL 5
rpm -q bash
bash-3.1-16.1

bash --version
GNU bash, version 3.1.17(1)-release (i686-redhat-linux-gnu)
Copyright (C) 2005 Free Software Foundation, Inc.

RHEL 4

rpm -q bash
bash-3.0-19.3.i386

bash --version
GNU bash, version 3.00.15(1)-release (i386-redhat-linux-gnu)
Copyright (C) 2004 Free Software Foundation, Inc.

Expected results:
That the versions would be consistent.
Comment 1 Tomas Janousek 2007-10-23 10:54:52 EDT
Yeah. The version is not supposed to reflect the patchlevel of bash. It's just a
package release number. I may consider putting the patchlevel to the Version
field. Other distributions don't seem to do this with bash though (e.g. Debian),
unlike with vim, for example.
Comment 2 Chris Ward 2007-10-24 05:42:09 EDT
Thanks for the feedback. 

What will cause you to decide one way or the other, to add or not add the
patchlevel to the version field?
Comment 3 Tomas Janousek 2007-10-24 07:01:55 EDT
Opinions of people who I do/should respect (including myself) :)
Comment 4 Chris Ward 2007-11-01 05:01:46 EDT
You can close this bug if you will not be acting on it. Please let me know.
Comment 5 Tomas Janousek 2007-11-13 11:15:49 EST
Closing because:
- we may want to back out a patch some day (which would make the version not
have any sense)
- other distros don't use this versioning with bash
- it's easier to leave it as it is :)

Note You need to log in before you can comment on or make changes to this bug.