Bug 34887 - Wolverine detects NetGear FA311 as Generic Natsemi
Wolverine detects NetGear FA311 as Generic Natsemi
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-05 10:51 EDT by Need Real Name
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 10:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-05 10:51:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; I; SunOS 5.7 sun4u)


Wolverine detects NetGear FA311 10/100 card as a "generic natsemi" and
installs inappropriate drivers for it.  If the driver is then removed, and
the kernal fa311.o module installed manually, kudzu then attempts to re-add
the natsemi card as an eth1, or eth2, etc.  each reboot attempt.  

By the way, I'm just guessing at it, but where are the kernel modules to be
added?

Such as with 7.0 Guiness, it's at:

/lib/modules/2.3.14-26/net/fa311.o
but the tree for Wolverine looks much different and has no net/ library in
the kernel module directory.
It's likely, then, this is a product of my own guesswork, but either way, I
don't think that the fa311 is a generic natsemi device, is it?


Reproducible: Sometimes
Steps to Reproduce:
1.Either perform a FRESH install from clean to Wolverine -or-	
2.Upgrade from Guiness to Wolverine
3.
	

Actual Results:  Generic Natsemi device is chosen for NetGear FA311 NIC.

Expected Results:  Either DON'T detect (as in Guiness) or properly detect
as Fa311 card.
Comment 1 Bill Nottingham 2001-04-05 10:55:30 EDT
There is no fa311 driver, unless you're talking about some other vendor-supplied
driver.

natsemi *is* the correct driver for that card.
Comment 2 Need Real Name 2001-04-05 13:32:59 EDT
Ok.  Yes, the fa311.o is a vendor supplied driver. Works fine on Guiness; just 
have to add an insmod -f since it has some undefined symbol problems with 
something called PAGE_OFFSET_RAW...

But, in the case of the upgrade, it left the existing eth0 specification in 
place (was pointing to Vendor supplied fa311.o module) and kudzu ADDED the 
natsemi to a non-existant eth1 device. At reboot, BOTH modules failed to 
initialize:

Bringing up interface eth0  [failed]
eth0 initialization will be delayed.

Bringing up interface eth1  [failed]
eth1 initialization will be delayed.

And networking didn't function at all...

On a fresh install, it added it as eth0, but still wouldn't initialize on boot.
Is the generic natsemi supposed to be 100% compatible with the NetGear fa311?

In any case, how about the other question posed:
"By the way, I'm just guessing at it, but where are the kernel modules to be
added?

Such as with 7.0 Guiness, it's at:

/lib/modules/2.3.14-26/net/fa311.o"

Thanks,
  Tony
Comment 3 Bill Nottingham 2001-04-05 13:55:00 EDT
natsemi should work. If it doesn't, that's a kernel problem.

The drivers are (for the 2.4 kernel) in /lib/modules/<version>/kernel/drivers/net/.

kudzu leaves the old alias for eth0 alone because it didn't create it, so
it's not 100% sure what it's supposed to be associated with hardware wise; it's
safer to leave it alone in this case.

Note You need to log in before you can comment on or make changes to this bug.