Bug 34903 - More experiences with X-4.0.3 on Alphas
More experiences with X-4.0.3 on Alphas
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-05 13:18 EDT by Michal Jaegermann
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-30 03:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample log file from a run with TNT2 card on Alpha (4.75 KB, application/octet-stream)
2001-04-05 13:19 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2001-04-05 13:18:30 EDT
I had an opportunity to try XFree86-4.0.3 on UP2000 Alpha with Nvidia
TNT2 graphics card (PCI).  All binaries were recompiled for glibc-2.1.
Both versions XFree86-4.0.3-3 and XFree86-4.0.3-5 were running on this
setup fine without any visible differences.  A default 1280x960 was
overdriving a bit a monitor on hands (not a very capable one) causing
some distortion on the top of a picture but after a dropping vsync
a bit, by making a picture shorter, things got corrected.  I attach
a log file from these runs just for a reference.

OTOH I tried the same XFree86-4.0.3-5 binaries on UP1100 Alpha with
Matrox G450 (AGP) card.  There were no problems once X server started
but it took a very long time to start, making an impression that it
already crashed, and I lost all visible text on a console (it become
black with very faint leftovers of parts of a picture from a gdm screen).
There are no effects of that sort if I am using XFree86-4.0.3-3 on
the same setup.

I will be investigating the situation with G450 further as time
permits.

  Michal
  michal@harddata.com
Comment 1 Michal Jaegermann 2001-04-05 13:19:29 EDT
Created attachment 14743 [details]
Sample log file from a run with TNT2 card on Alpha
Comment 2 Mike A. Harris 2001-05-25 05:30:14 EDT
Can you please attach your config, and a new log file from a run of
XFree86-4.0.3-17 from ftp://people.redhat.com/mharris/testing

Also, just a note for future attachments - please do not compress file
attachments, I can't view them easily.
Comment 3 Michal Jaegermann 2001-05-25 12:06:46 EDT
> Can you please attach your config, and a new log file
I am afraid that not in this moment as I do not have a single TNT2
around as of this time.   Maybe sometimes in the future.
Comment 4 Phil Copeland 2001-06-04 15:33:03 EDT
This bug is deferred...
Comment 5 Michal Jaegermann 2001-06-11 15:36:49 EDT
I still have no TNT2 to try but recently we were running Alpha UP1500
with Nvidia Geoforce MX.  Not precisely the same thing but at least the
same driver. :-)  In a "normal usage" no troubles were observed with
4.0.3-15 as opposed to 4.0.3-9 which was loosing text colours if one
would try to switch to a text console.
Comment 6 Mike A. Harris 2002-05-30 03:52:43 EDT
Assuming this works in latest XFree86 release for Alpha (4.1.0-26).  If not,
try 4.2.0 from rawhide.  Realistically if it doesn't work, we can't do much
at all about Nvidia bugs due to complete lack of documentation.
Comment 7 Michal Jaegermann 2002-05-30 11:34:00 EDT
Hm, this note from over a year ago basically said that things were running
ok on a somewhat "exotic" setup after some adjustments.  I am afraid that
for a very long time now I did not see such machine with such video card.
I did hear later complaints later on from somebody with something similar
and I understand that his situation is indeed much better with binaries from
current rawhide.  With various current video cards rawhide is practically
the only realistic option (especially that various 4.1.0 releases had
a tendency to kill a text console with assorted cards - see, for example,
#61325 - and this was not happening with 4.2.0).  A video card I have right
now (ATI 7500) does not really work with anything below 4.2.0, i.e. rawhide.
Comment 8 Mike A. Harris 2002-05-30 18:36:41 EDT
Ok, good to hear it seems to work now.  A bit of confusion in the above though..
Current rawhide is 4.2.0, and nothing should have changed in rawhide that
doesn't also exist in RHL 7.3.  However... we don't have RHL 7.3 for Alpha
either.  ;o)

You're right on the 7500 - support for it was added first to 4.2.0.  I'm trying
to keep the packages building and working on Alpha as well as x86.  Right now
Alpha build is disabled due to a bug I haven't had time to fix, but I believe
I can fix it easily.  It should be re-enabled within a week or so likely.

Dunno how well the current gcc 3.1 stuff runs on Alpha though.. I build it
but haven't ran it...  Once I get bigger disks in my Alphen, I'll probably
set up multibooting.

Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.