Bug 34911 - Default dbconfig options contain unrecognized
Default dbconfig options contain unrecognized
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-05 14:52 EDT by Greg Hudson
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 14:52:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Hudson 2001-04-05 14:52:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.14-12 i686)


In lib/dbconfig.c, the variable db3_config_default contains the option
"db3", which
is not a recognized option in rdbOptions[].  As a result, when the default
options are
used (which seems to be the case if the RPM database is rpm rpm 3.x), one
gets
a spurious error message.

Reproducible: Always
Steps to Reproduce:
1. Install Red Hat 6.2 (but don't take the rpm-4.0.2-6.x upgrade, of
course).
2. Get a copy of /bin/rpm from a Red Hat 7 machine (with or without the
rpm-4.0.2
    upgrade).
3. Run a simple rpm query, like "rpm -q kernel".
	

Actual Results:  dbiSetConfig: unrecognized option: "db3" ignored.
dbiSetConfig: unrecognized option: "db3" Ignored
kernel-2.2.14-12

Expected Results:  kernel-2.2.14-12
Comment 1 Jeff Johnson 2001-04-06 13:08:38 EDT
You can't just take a binary from Red Hat 7.x and run it on Red Hat 6.x. Even
though
rpm is statically linked, that just means that dlopen() is used to load various
necessary
modules. There's other lossage, including incompatible i18n structures, and
probably
db3 lossage as well.

Use the version of rpm compiled for Red Hat 6.x, AFAIK, there are no problems
(and no differences in configuration) in that package. However, please reopen
this bug if I'm wrong.

Note You need to log in before you can comment on or make changes to this bug.