Bug 34913 - Type1 fonts from XFree86-ISO8859-2 (qa0404) cannot be used
Type1 fonts from XFree86-ISO8859-2 (qa0404) cannot be used
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-05 15:02 EDT by Michal Jaegermann
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-05 23:55:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-04-05 15:02:49 EDT
All fonts from Type1 subdirectory ("ult1mo" registry) of this package
when selected in a font selector (stand-alone gfontsel or from
gnome-terminal) result only in an error message "This font is not
available" or something of that sort (from memory).  The same fonts
when used with gfontsel from RH 6.2 distribution are simply crashing
that application.

There are no such such troubles with "ult1mo" fonts when they are replaced
by XFree86-ISO8859-2-Type1-fonts-1.0-12.noarch.rpm package from RH7
distribution.

As an aside my old #27072 report about fonts (look at pictures
attached to it) does not seem to be resolved at all even if a final release
seems to be very close.

  Michal
  michal@harddata.com
Comment 1 Mike A. Harris 2001-04-08 09:00:30 EDT
The XFree86-ISO8859-2 was obsoleted in the development cycle post Guinness.
I've changed the package component to reflect this, as this is the first time
I've seen this bug report.

The functionality was incorporated into XFree86, however it seems it is not
done completely correctly.

I will look into this issue deeper when I have time to delve into the
complexities of XFree86 font generation, etc..
Comment 2 Mike A. Harris 2002-03-09 11:04:33 EST
The XFree86 package itself,and all subpackages produced contain only fonts that
come from XFre86.org sources now.

All other fonts are in their own external packages and no packages have
XFree86 in their name unless they are part of XFree86.  All font packages
external to X are now named fonts-* or ttfonts-* (or should be).

The new package for these fonts is fonts-ISO8859-2 in rawhide.  Please
let me know if this package is broken, as I believe it to be ok now.
Comment 3 Michal Jaegermann 2002-03-09 12:28:12 EST
See #60641 for a solution.
Comment 4 Michal Jaegermann 2002-03-09 12:36:47 EST
> The new package for these fonts is fonts-ISO8859-2 in rawhide.

These all are bitmaps fonts in a pcf.gz format.  Although their presence
is nice we are talking here about scalable fonts and problems with the
later seem to be "solved" by removing them from subsequent distributions.
Web browsers, for example, have a hard time with bitmap fonts.

Note You need to log in before you can comment on or make changes to this bug.