Bug 34916 - Cross/Up-sale has issues
Cross/Up-sale has issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: New Store (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cameron Prince
wbirkhea
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-05 15:24 EDT by Jay Turner
Modified: 2015-01-07 18:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 09:20:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2001-04-05 15:24:23 EDT
Pull up http://cprince.devel.webdevel.redhat.com/cgi-bin/store and place
one of the Professional Server boxes in the cart.  Will get taken to the
cart and there will be a T-shirt listed in the Additional Items section. 
Click buy on this, thus adding it to the cart.  Now the list of suggested
items changes, and the new list will include "Red Hat Professional Server"
 It's already in the cart, we should not be suggesting that the user
purchase this product.
Comment 1 Jason Kohles 2001-04-23 15:14:23 EDT
Fixed, items in the cart are now prevented from appearing in the
crosssell/upsell list.
Comment 2 Jay Turner 2001-04-23 15:19:27 EDT
Looks like we know have debugging statements appearing just below the Cancel
Order button.  Looks like the part numbers for the cross-sell or something like
that.  Other than that, the only issue that I see is if the customer has all of
the cross-sell items in their cart, then we get "You might also like" and
nothing.  Looks a little odd.
Comment 3 Jason Kohles 2001-04-23 16:32:24 EDT
That was the cross_sell list, so I could make sure the items were actually
getting removed, I just hadn't saved the file after deleting it yet, it's gone
now.
Comment 4 Jason Kohles 2001-04-24 09:19:59 EDT
I've modified the cart to not display the 'You might also like' text if no
cross_sell items could be found.
Comment 5 Jay Turner 2001-04-24 15:55:12 EDT
This appears to be cleared up on webdevel, so I'm closing out the issue.

Note You need to log in before you can comment on or make changes to this bug.