Bug 349171 - imlib2 should not use --enable-mmx on ia64
imlib2 should not use --enable-mmx on ia64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imlib2 (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2007-10-23 14:04 EDT by Doug Chapman
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 17:07:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2007-10-23 14:04:57 EDT
Description of problem:
The spec file for imlib2 incorrectly has --enable-mmx for ia64 which does not build.

%ifarch %{ix86} ia64

asmopts="--enable-mmx --disable-amd64"

%endif



this should be changed to:
%ifarch %{ix86}
asmopts="--enable-mmx --disable-amd64"

%endif



Version-Release number of selected component (if applicable):
imlib2-1.4.0-3.fc8

How reproducible:
100%

Steps to Reproduce:
1. build imlib2 on ia64
2.
3.
  
Actual results:
Lots of asm errors since x86 asm code is used


Expected results:
clean build


Additional info:
Comment 1 Hans de Goede 2007-10-23 17:07:10 EDT
1.4.0-4, which fixes this, should show up in rawhide once F-8 is
released and rawhide unfreezes at the start of the F-9 development cycle.

Note You need to log in before you can comment on or make changes to this bug.