Bug 349201 - Nvidia 8600 not detected during installation or post installation
Nvidia 8600 not detected during installation or post installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 14:24 EDT by Barry Powell
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 11:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda installation log - nVidia Corporation Unknown device 0402 (43.89 KB, text/plain)
2007-10-23 17:36 EDT, Barry Powell
no flags Details
Manual attempt to start X (55.16 KB, text/plain)
2007-10-23 17:42 EDT, Barry Powell
no flags Details
working setup log with vesa driver (918 bytes, text/plain)
2007-10-27 07:40 EDT, Barry Powell
no flags Details
working xorg.log using veas driver (55.39 KB, text/plain)
2007-10-27 07:41 EDT, Barry Powell
no flags Details

  None (edit)
Description Barry Powell 2007-10-23 14:24:00 EDT
Description of problem:


Nvidia 8600GT Card not detected during installation. So cannot perform graphical
installation. Text mode installs works.


How reproducible:


Steps to Reproduce:
1. Boot from f8test3 (7.92) DVD
2. No boot menu displayed - wait for auto install (or hit return)
3. Anaconda start detecting hardware - You will see something like "NVIDIA
Unknown Device 0402". The installation continues, without any further display.
  
Actual results:
Blank screen

Expected results:
Graphical installer to start

Additional info:
CPU: Intel Quad Core - G0 stepping
Mobo: Giga-byte GA-P35-DS4  - Firmware F7 (latest)


Upon completing installation, X fails to start. No logs at the moment.
From what I can pci id 10de:0402 should be supported from
/usr/share/hwdata/videoaliases/nv.xinf
Comment 1 Barry Powell 2007-10-23 17:36:01 EDT
Created attachment 235591 [details]
Anaconda installation log - nVidia Corporation Unknown device 0402

I checked Xorg.setup.log, however this is just an empty file.
Comment 2 Barry Powell 2007-10-23 17:42:21 EDT
Created attachment 235611 [details]
Manual attempt to start X

This log was either a startx or system-config-display that I ran. Again X did
not start and the monitor could not detect a single on either DVI or analog
inputs.  I'm not sure that I can see anything wrong with this though. 

I should add that this all works under Windows, so the hardware is okay.
Comment 3 Barry Powell 2007-10-27 07:38:51 EDT
Graphics card is running the latest VBIOS available.

Installed all updates to date - nv driver displays a corrupted display and
'locks' the system up. As I can't create a virtual console, I'm not sure what is
actually going on. 

My work around for now is to use the vesa driver. I'm not sure why anaconda
doesn't fail back to this driver, when it fails to start X (or even if it is
supposed to). As we are so near to FC8 being released, I'll probably have to
install via kickstart (and specify xdriver=vesa) for when FC8 finally gets released.

I'll test again on the next test release and update here. Is there anything
useful I can provide in the mean time?
Comment 4 Barry Powell 2007-10-27 07:40:32 EDT
Created attachment 240261 [details]
working setup log with vesa driver
Comment 5 Barry Powell 2007-10-27 07:41:22 EDT
Created attachment 240271 [details]
working xorg.log using veas driver
Comment 6 Barry Powell 2007-10-28 18:13:35 EDT
Problem solved.  The root cause for my problem, was a 4-port USB pci card, which
I had moved from my old machine into this new one.  I guess that it was not
compatible with the later style PCI slots of my new machine. 

After I removed the USB card. I tested both a text based and a graphical
installation. 

The cdrom boot menu is now being correctly displayed. 

During a graphical installation, I still get the "NVIDIA
Unknown Device 0402" message. However the installation works just fine in a
800x600 display (my LCD screen doesn't like it much) and correctly configures
xorg.conf to use the nv driver.  The screen resolution is correctly detected
after the reboot.

Please close this as not-a-bug. Hardware problem.
Comment 7 Matěj Cepl 2007-10-31 11:02:35 EDT
Closing per reporter's request. Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.