Bug 349321 - %_sysconfdir is wrong on x86_64
%_sysconfdir is wrong on x86_64
Status: CLOSED DUPLICATE of bug 211119
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Depends On:
  Show dependency treegraph
Reported: 2007-10-23 15:14 EDT by Jonathan Reed
Modified: 2007-11-16 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-24 04:15:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonathan Reed 2007-10-23 15:14:31 EDT
Description of problem:

%_sysconfdir points to /usr/etc on x86_64 platforms
It should point to /etc like it does on other platforms.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run "rpm --eval %_sysconfdir" on an x86_64 machine.
2. See that the result is "/usr/etc"
3. Run "rpm --eval %_sysconfdir" on an i386 machine.
4. See that the result is "/etc"
5. See that "/usr/etc" is not the same as "/etc"
Actual results:

[some-64-bit-machine ~]$ rpm --eval %_sysconfdir

Expected results:

[some-32-bit-machine ~]$ rpm --eval %_sysconfdir

Additional info:

This was first reported in RHEL3 as bug 190800.  Of course, that bug stagnated
for years and then was closed by the automatic bot last week.  

From the previous bug, there's an easy fix, but really, there should not be
platform skew to begin with:

-- Additional comment from n3npq@mac.com on 2006-03-23 15:33 EST --
The %{_sysconfdir} macro is overridden by per-platform macros
    -14: _sysconfdir        /etc

Edit /etc/rpm/platform, and change "ia32e" to "x86_64" is one fix.
    ln -s x86_64-linux /usr/lib/rpm/ia32e-linux

-- Additional comment from tr@bgs-ing.de on 2006-03-24 08:16 EST --
The symlink was what I thought of, too.
I did:
ln -s /usr/lib/rpm/x86_64-linux/ /usr/lib/rpm/ia32e-linux

and now it works:

# rpm --eval %{_sysconfdir}
Comment 1 Panu Matilainen 2007-10-24 04:15:21 EDT

*** This bug has been marked as a duplicate of 211119 ***

Note You need to log in before you can comment on or make changes to this bug.