Bug 349451 - Watchpoints missed after inferior's fork()
Watchpoints missed after inferior's fork()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gdb (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jan Kratochvil
:
Depends On: 237096
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 16:24 EDT by Jan Kratochvil
Modified: 2008-07-24 15:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0717
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:56:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2007-10-23 16:24:34 EDT
+++ This bug was initially created as a clone of Bug #237096 +++

-- Additional comment from jan.kratochvil@redhat.com on 2007-10-15 11:26 EST --
I guess I found the problem during an unrelated gdb-on-gdb debugging.

The problem is fork()ing of the debugged program.
fork() there disarms the hardware watchpoints (they still appear as active but
they get unset from the hardware registers).
It affects:
RHEL-4.6beta
RHEL-5.1beta
gdb-6.6 upstream
gdb-6.7 upstream
gdb cvs upstream

Fedora8/development binary + source rpm:
  http://koji.fedoraproject.org/koji/buildinfo?buildID=20928
.src.rpm there is easily `rpm --rebuild'-able at least on RHEL-5.
Patch posted upstream:
  http://sources.redhat.com/ml/gdb-patches/2007-10/msg00367.html

It should (no guarantees can be made) get fixed in RHEL-4.7 and RHEL-5.2.

-- Additional comment from jan.kratochvil@redhat.com on 2007-10-23 16:21 EST --
Fixed in Rawhide (and F8):
* Fri Oct 19 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.6-37
- Fix hiding unexpected breakpoints on intentional step/next commands.
Comment 1 RHEL Product and Program Management 2007-11-28 22:56:15 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Andrew Cagney 2007-12-04 12:44:03 EST
dev-ack+

Partial fix available (needs documentation update).

Change driven by customer issue.
Comment 7 errata-xmlrpc 2008-07-24 15:56:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0717.html

Note You need to log in before you can comment on or make changes to this bug.