Bug 34973 - XFree86-4.0.3-5.src.rpm rebuild problem
XFree86-4.0.3-5.src.rpm rebuild problem
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-06 03:14 EDT by John J. Germs
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-02 21:13:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John J. Germs 2001-04-06 03:14:03 EDT
I was going to be helpfull and submit a --rebuild bug.
I typed everything in ... I really did.
But I had filled in the Component Text feild with XFree86-4.0.3-5.src.rpm
and when I went to submit it it said that I was supposed to leave the feild
blank. "Hit the Back key and empty the feild" ..... Well I did this and
lost everything I typed in...... This bug submitting program should have
had a clickable icon to bring me back to the form.
This may be because I'm using Mozilla but still. .... grrrr

Anyways the error was after an hour and ten minutes of going thru an:
rpm --rebuild --target=i686 XFree86-4.0.3-5.src.rpm

It had to do with appres...... 
something about a bad reference to ..... 

Darn it ... I can't remember the details anymore and have already closed
the terminal I was using.
 Is there a place where the cosole output would have been stored?? ... I
don't want to do the whole proccess of rebuild over again just so I can
type it in this form.....
Comment 1 Mike A. Harris 2001-04-06 11:31:30 EDT
The component field is a "shortcut" way of entering the component name
if you know it rather than picking it from the list.  The component name
is "XFree86".  You put in the source package name which is incorrect.  I
agree though that the form could be more clear on this issue as I believe
I have done the same in days gone by.  Please file a bugzilla request
for enhancement against bugzilla itself to have the form become more self
documenting.

As for the build failure you experienced, I can't do much without seeing the
relevant lines from the build failure.  When you build RPM packages you might
want to try:

rpm --rebuild <package> 2>&1 | tee xbuild.out

This allows you to watch it build and log it to xbuild.out simultaneously.
I've been building XFree86 4.0.3 in Guinness here at home.  As long as you
have updated freetype and flex packages installed, it should build ok I think.

If you update the report with the relevant error text, I'll see if I can
assist you.
Comment 2 John J. Germs 2001-04-06 20:41:28 EDT
Thank you for your patience and understanding.... 
Here is the output of the error:


install -c -m 0444 mk_MK.UTF-8
/var/tmp/XFree86-4.0.3-root/usr/X11R6/lib/X11/locale/mk_MK.UTF-8/Compose
install -c -m 0444 mulelao-1
/var/tmp/XFree86-4.0.3-root/usr/X11R6/lib/X11/locale/mulelao-1/Compose
install -c -m 0444 th_TH.TACTIS
/var/tmp/XFree86-4.0.3-root/usr/X11R6/lib/X11/locale/th_TH.TACTIS/Compose
install -c -m 0444 vi_VN.tcvn
/var/tmp/XFree86-4.0.3-root/usr/X11R6/lib/X11/locale/vi_VN.tcvn/Compose
install -c -m 0444 vi_VN.viscii
/var/tmp/XFree86-4.0.3-root/usr/X11R6/lib/X11/locale/vi_VN.viscii/Compose
install -c -m 0444 zh
/var/tmp/XFree86-4.0.3-root/usr/X11R6/lib/X11/locale/zh/Compose
install -c -m 0444 zh_TW
/var/tmp/XFree86-4.0.3-root/usr/X11R6/lib/X11/locale/zh_TW/Compose
install -c -m 0444 zh_TW.big5
/var/tmp/XFree86-4.0.3-root/usr/X11R6/lib/X11/locale/zh_TW.big5/Compose
install in nls/Compose done
make[3]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/nls/Compose'
make[2]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/nls'
installing in ./programs...
make[2]: Entering directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/programs'
installing in programs/appres...
make[3]: Entering directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/programs/appres'
rm -f appres
gcc -o appres -O2 -march=i686 -ansi -pedantic -Wall -Wpointer-arith    
-L../../exports/lib appres.o -lXt -lSM -lICE -lXext -lX11     
-Wl,-rpath-link,../../exports/lib
../../exports/lib/libXt.so: undefined reference to `atexit'
collect2: ld returned 1 exit status
make[3]: *** [appres] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/programs/appres'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/programs'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc'
make: *** [install] Error 2
make: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc'
Bad exit status from /var/tmp/rpm-tmp.52215 (%install)
Comment 3 Mike A. Harris 2001-04-06 21:40:49 EDT
Hmm.  atexit() is defined in <stdlib.h>
Unless you're building in Red Hat Linux 6.x or something older perhaps,
or are using some other compiler or C libraries than what ship with the
distro, it should work in Red Hat Linux 7.0 or higher.  What distro are
you using?

Does it build if you leave the --target off?
Also, it should be "--target i686".  There should be _no_ "=" sign there.
Previous versions of the rpm manpage incorrectly put an "=" sign there,
but it is not correct.  The "popt" library does not support the GNU style
"=" syntax.

I will try doing an i686 build here and report back.

Comment 4 John J. Germs 2001-04-06 23:43:20 EDT
flex is at 2.5.4a-13 (rawhide)
freetype is at 2.0.1-2 (rawhide)
There is a freetype 2.0.1-4 (rawhide) that I will try installing.

I'm using RedHat 7.0 with updated gcc-2.96-69 also from rawhide. I will try
updating to gcc-2.96-80 and see if that makes a difference.

If I try a --target i686 it reports:
error cannot open i686: No such file or directory
But the --target=i686 has always worked for me.

If that still doesn't work I will try leaving off the --target and see what it does.
Comment 5 John J. Germs 2001-04-07 03:13:58 EDT
Installed freetype-2.0.1-4
rebuilt gcc-2.96-80.src.rpm and upgraded all that it provided.

I thought that solved it, but it still got an `atexit' error farther down.
Here is the error:

+ install -c -m 0755 GiveConsole
/var/tmp/XFree86-4.0.3-root/etc/X11/xdm/GiveConsole
+ install -c -m 0755 TakeConsole
/var/tmp/XFree86-4.0.3-root/etc/X11/xdm/TakeConsole
+ install -c -m 0755 Xsetup_0 /var/tmp/XFree86-4.0.3-root/etc/X11/xdm/Xsetup_0
+ install -c -m 0755 Xwilling /var/tmp/XFree86-4.0.3-root/etc/X11/xdm/Xwilling
+ mkdir -p /var/tmp/XFree86-4.0.3-root/etc/X11/xdm/pixmaps
+ install -c -m 0444 XFree86.xpm
/var/tmp/XFree86-4.0.3-root/etc/X11/xdm/pixmaps/XFree86.xpm
+ install -c -m 0444 XFree86bw.xpm
/var/tmp/XFree86-4.0.3-root/etc/X11/xdm/pixmaps/XFree86bw.xpm
install in programs/xdm/config done
make[4]: Leaving directory
`/usr/src/redhat/BUILD/XFree86-4.0.3/xc/programs/xdm/config'
make[3]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/programs/xdm'
installing in programs/xdpyinfo...
make[3]: Entering directory
`/usr/src/redhat/BUILD/XFree86-4.0.3/xc/programs/xdpyinfo'
rm -f xdpyinfo
gcc -o xdpyinfo -O2 -march=i686 -ansi -pedantic -Wall -Wpointer-arith    
-L../../exports/lib xdpyinfo.o -lXtst -lXIE -lxkbfile -lXxf86vm -lXxf86dga
-lXxf86misc -lXi -lXext -lX11   -lm   -Wl,-rpath-link,../../exports/lib
../../exports/lib/libXxf86dga.so: undefined reference to `atexit'
collect2: ld returned 1 exit status
make[3]: *** [xdpyinfo] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/XFree86-4.0.3/xc/programs/xdpyinfo'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/programs'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc'
make: *** [install] Error 2
make: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc'
Bad exit status from /var/tmp/rpm-tmp.20675 (%install)

I'll try it without target yet, but don't hold much hope.

Any ideas??
Comment 6 John J. Germs 2001-04-08 00:14:47 EDT
I decided to try downgrading gcc and dependencies to the original RedHat 7
cpp-2.96-54
gcc-2.96-54
gcc-c++-2.96-54
gcc-g77-2.96-54
gcc-odjc-2.96-54
libstdc++-2.96-54
libstdc++-devel-2.96-54

I received the same appres (`atexit' error) as before.
I tried this with:
rpm --rebuild --target=i686 XFree86-4.0.3-5.src.rpm
and without the --target
rpm --rebuild XFree86-4.0.3-5.src.rpm
Comment 7 Mike A. Harris 2001-04-08 05:22:29 EDT
I'm terribly sorry... I misled above.  I don't know what glue I was
on there...  The target option MUST have an "=" on it.. I reversed things
by accident.  I was thinking it right, but typed it in backwards.  ;o)

The XFree86 rpm's currently should build in the current rawhide environment,
as well as pretty much any snapshot of rawhide since December or so.  It
also should build in an up to date 7.0 dist with a few rawhide packages
added.  If you're running 7.0, then make absolutely sure that you have _all_
errata packages updated on your system.  After making sure of this, install
the dependancies that X requires, and it should compile.  My main workstation
is running stock 7.0 + updates + a few packages from rawhide (flex, freetype,
Mesa, XFree, and perhaps a few other dinky things).  If it does not compile
after ensuring all of this, I'm at a loss.  Perhaps you've encountered a
build dependancy that hasn't been discovered yet...  It is entirely possible,
and if true, it would be great to track down.

I am hoping to release a 4.0.3 package for Red Hat Linux 7.0 at some point
for errata.  It won't likely be for a month or so though if not more..
Comment 8 Mike A. Harris 2001-06-01 01:55:24 EDT
Do you have the glibc-devel package installed?
Comment 9 John J. Germs 2001-06-02 21:13:35 EDT
Thanks for doing a back check on things, but I gave up on it and just grabbed
the 4.0.3-5 from the RedHat 7.1 disc when it came out ... It would have been
nice to find out what the problem is/was, but I have since upgraded my system
with the RedHat7.1 discs... So I'm on to other things.

Thanks for your efforts,

...G...
Comment 10 Mike A. Harris 2001-06-03 05:57:50 EDT
Ok, looks like you're all set.

Note You need to log in before you can comment on or make changes to this bug.