Bug 349871 - python-psyco needs to remove Requires: python-abi = line in spec
python-psyco needs to remove Requires: python-abi = line in spec
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: python-psyco (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ignacio Vazquez-Abrams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 22:50 EDT by Matt Domsch
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 23:04:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2007-10-23 22:50:20 EDT
Description of problem:
For Fedora 8, python is no longer included in the default buildroot.  By having
a line in the spec file:

Requires:   python-abi = %(%{__python} -c "import sys ; print sys.version[:3]")

when python isn't in the buildroot, that turns into an illegal Requires: line
(there's nothing after the equals sign), and rpmbuild fails.

Version-Release number of selected component (if applicable):
1.5.1-5

How reproducible:
always

Steps to Reproduce:
1. mock rebuild python-psyco-1.5.1-5.fc7.src.rpm
  
Actual results:
build failure

Expected results:
build success

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2007-10-23 23:04:32 EDT
The fix is in 1.5.1-6 but I'm not going to tag and build it since it doesn't
affect runtime capabilities.

Note You need to log in before you can comment on or make changes to this bug.