Bug 349921 - kernel with ieee1394 module not present
kernel with ieee1394 module not present
Status: CLOSED DUPLICATE of bug 428554
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-23 23:41 EDT by Andrew Farris
Modified: 2008-01-13 02:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-13 02:38:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screen image of kernel messages (87.06 KB, image/jpeg)
2007-11-04 06:37 EST, Andrew Farris
no flags Details
screen image of kernel messages (89.67 KB, image/jpeg)
2007-11-04 06:38 EST, Andrew Farris
no flags Details
screen image of kernel messages (98.95 KB, image/jpeg)
2007-11-04 06:38 EST, Andrew Farris
no flags Details

  None (edit)
Description Andrew Farris 2007-10-23 23:41:08 EDT
Description of problem:

On installation of kernel-, also happened with
WARNING: No module ieee1394 found for kernel, continuing anyway

Version-Release number of selected component (if applicable):

Expected results:
Module should be present for distribution kernel.
Comment 1 Jeremy Katz 2007-10-24 17:41:31 EDT
Is this when updating the kernel?  What are the contents of your /etc/modprobe.conf?
Comment 2 Andrew Farris 2007-10-24 21:39:56 EDT
Updating from 2.6.23-6.fc8.  This system has been updating to devel for a long
time (fc5 may have been last time it was cleanly installed).

2.6.23-6 handles my firewire disk fine with the configuration as is, both the
kernels listed above give this error AND cannot mount the firewire disk.


alias scsi_hostadapter sbp2
alias scsi_hostadapter1 usb-storage
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1
remove snd-intel8x0 { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
alias eth0 tulip
alias eth1 3c59x
alias wlan0 rt2500pci
alias eth2 rndis_host
options snd cards_limit=8
alias snd-card-7 snd-usb-audio
options snd-usb-audio index=7
Comment 3 Jeremy Katz 2007-10-24 22:15:20 EDT
I suspect the message will go away if you change sbp2 to firewire-sbp2 in
Comment 4 Andrew Farris 2007-10-25 05:05:03 EDT
The message indeed goes away when that change is made, however it doesn't make
the kernel work when its installed.  Both kernel and
have kernel panics very early in the boot process, with messages about
firewire_sbp2.  I'll get back to this in a couple days and perhaps get the
messages posted (not quite the same thing happening for both kernels, different
messages but both still panic).
Comment 5 Andrew Farris 2007-11-04 06:35:58 EST
I'm still having issues with these kernels and the external firewire drive, but
beginning to think its due to my hardware and its odd drive sleep behavior.  I
have had trouble with the kernel letting the drive power down and losing
connection to it despite still thinking the drive is mounted... this has been
going on for months, but the booting issues are new within a few weeks.

All rawhide kernels after 2.6.23-6 still have the same or similar failure to
boot if the drive enclosure power is ON at boot time, but they all boot fine and
access the drive if it is not turned on until after booting (I have only really
tried waiting until I login to X, so I'm assuming that once kernel modules are
loaded and disk checks are done it would probably be fine to turn it on).  If
the drive has power when the kernel starts booting it fails every time.

To clarify that it fails if:
- power down machine, leave external drive power on (drive just parked)
- power machine on, external drive seems not to wake up

The kernel boots fine if:
- power down machine, turn off external drive power
- power machine on, leave drive power off until after login
- drive is auto mounted and works fine for hours

The drive is a western digital caviar internal 120gb ata133 drive in an I-Rocks
usb2/firewire external enclosure.

Here are two links to pictures of the screen when this happens; I know they are
hard to read at all.

There are repeated messages of: firewire_sbp2: orb reply timed out, rcode=0x11
Comment 6 Andrew Farris 2007-11-04 06:37:15 EST
Created attachment 247551 [details]
screen image of kernel messages
Comment 7 Andrew Farris 2007-11-04 06:38:01 EST
Created attachment 247561 [details]
screen image of kernel messages
Comment 8 Andrew Farris 2007-11-04 06:38:25 EST
Created attachment 247571 [details]
screen image of kernel messages
Comment 9 Andrew Farris 2008-01-13 02:38:17 EST

*** This bug has been marked as a duplicate of 428554 ***

Note You need to log in before you can comment on or make changes to this bug.