Bug 3501 - xfs doesn't open a TCP socket
xfs doesn't open a TCP socket
Status: CLOSED DUPLICATE of bug 2759
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-16 10:20 EDT by mark.kennedy
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-16 14:09:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark.kennedy 1999-06-16 10:20:47 EDT
the xfs man page says that xfs opens TCP port 7100
by default.  however, commands which attempt to use
that port (xset, fsinfo, fslsinfo) fail indicating
that xfs isn't listening.  "lsof -p <xfs process>"
says:


# lsof -p 2120
COMMAND  PID USER   FD   TYPE     DEVICE    SIZE  NODE NAME
xfs     2120  xfs  cwd    DIR        3,5    1024     2 /
xfs     2120  xfs  rtd    DIR        3,5    1024     2 /
xfs     2120  xfs  txt    REG        3,5  391872 49207
/usr/X11R6/bin/xfs
xfs     2120  xfs  mem    REG        3,5  342206 28736
/lib/ld-2.1.1.so
xfs     2120  xfs  mem    REG        3,5  538944 28748
/lib/libm-2.1.1.so
xfs     2120  xfs  mem    REG        3,5 4016683 28741
/lib/libc-2.1.1.so
xfs     2120  xfs  mem    REG        3,5  251436 28772
/lib/libnss_nisplus-2.1.1.so
xfs     2120  xfs  mem    REG        3,5  364235 28749
/lib/libnsl-2.1.1.so
xfs     2120  xfs  mem    REG        3,5  243964 28766
/lib/libnss_files-2.1.1.so
xfs     2120  xfs    0u   CHR        1,3          2051
/dev/null
xfs     2120  xfs    1u   CHR        1,3          2051
/dev/null
xfs     2120  xfs    2u   CHR        1,3          2051
/dev/null
xfs     2120  xfs    3r  FIFO        0,0         33619 pipe
xfs     2120  xfs    4r  FIFO        0,0         33621 pipe
xfs     2120  xfs    5u   CHR      136,0             2
/dev/pts/0
xfs     2120  xfs    6r  FIFO        0,0         33804 pipe
xfs     2120  xfs    7u  sock        0,0         33814 can't
identify protocol
xfs     2120  xfs    8u  unix 0xccdbe8c0         33815
/tmp/.font-unix/fs-1
xfs     2120  xfs   10r  FIFO        0,0         33798 pipe
xfs     2120  xfs   12u   CHR      136,0             2
/dev/pts/0
xfs     2120  xfs   21w  FIFO        0,0         33798 pipe
#

which suggests that it has created a socket but not
bound a protocol (like TCP) nor a protocol endpoint
(like 7100) to it?
Comment 1 Jeff Johnson 1999-06-16 14:09:59 EDT
*** This bug has been marked as a duplicate of 2759 ***

Note You need to log in before you can comment on or make changes to this bug.