Bug 350141 - frame rate drops to 0 with the free radeon driver.
frame rate drops to 0 with the free radeon driver.
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-24 05:02 EDT by Eliran Itzhak
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-16 07:07:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
my xorg.conf (1.15 KB, application/octet-stream)
2007-10-24 11:46 EDT, Eliran Itzhak
no flags Details
/var/log/Xorg.0.log from using fglrx. (49.07 KB, text/plain)
2007-10-24 11:47 EDT, Eliran Itzhak
no flags Details
2 (61.60 KB, text/plain)
2007-10-24 11:47 EDT, Eliran Itzhak
no flags Details
3 (865 bytes, text/plain)
2007-10-24 11:48 EDT, Eliran Itzhak
no flags Details

  None (edit)
Description Eliran Itzhak 2007-10-24 05:02:12 EDT
Description of problem:
One of the latest updates to the "radeon" free driver broke it.
As I dont restart after every update, the problem started today, just after
restarting the machine.
The problem is with playing video, where the frame rate drops to 0 after a
minute or two of playing the video.
I've checked with mplayer, kplayer & vlc, with good avi/mpg files (that worked
When running mplayer from the command line I get NO error msgs when the frame
rate drops to 0.
Version-Release number of selected component (if applicable):

How reproducible:
install the free radeon driver and try to play some video.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
After installing the prop' ATI driver from livna, the problem went away, so I'm
quite sure the problem is with the radeon driver.
Please note that I've tried several "video out" options with Kplayer, with the
same problem with all of them. plays for a minute or two, then the frame rate
drops to 0.
Comment 1 Eliran Itzhak 2007-10-24 05:14:31 EDT
My mistake, the problem is here even with the ATI provided driver.
I was just lucky to play 1 video without problems, So I assumed the problem went
I also have sound problems, where the sound "goes away" for few minutes and then
come back.
Comment 2 Eliran Itzhak 2007-10-24 06:18:46 EDT
After some more testing, SEEMS like switching from ALSA to OSS in the kplayer
configuration screen, made the problem go away. (i think :-)
Lemme know if you need more info on that.
Comment 3 Till Maas 2007-10-24 07:57:08 EDT
I guess you selected the wrong component here. I guess the ati driver you are
talking about is in the package xorg-x11-drv-ati. radeontool is not a driver but
only a tool to use some functions of a radeon based graphic card.
Comment 4 Matěj Cepl 2007-10-24 10:05:16 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Eliran Itzhak 2007-10-24 11:46:53 EDT
Created attachment 236291 [details]
my xorg.conf
Comment 6 Eliran Itzhak 2007-10-24 11:47:25 EDT
Created attachment 236301 [details]
/var/log/Xorg.0.log from using fglrx.
Comment 7 Eliran Itzhak 2007-10-24 11:47:46 EDT
Created attachment 236311 [details]
Comment 8 Eliran Itzhak 2007-10-24 11:48:21 EDT
Created attachment 236321 [details]
Comment 9 Eliran Itzhak 2007-10-24 11:50:21 EDT
I cannot load my X without any configuration files atm, sorry.
I've uploaded the configuration files you've asked for.
Lemme know if you need anything else.
Comment 10 Matěj Cepl 2007-10-25 09:22:56 EDT
Could you please explain me what are attachments 2 and 3, I was not able to
decipher it.
Comment 11 Eliran Itzhak 2007-10-25 09:28:28 EDT
I've sent you the the files you wanted, in that order. Xorg.0.log,  Xorg.20.log,
The files are from  /var/log
Lemme know if you need any other files.
Comment 12 Matěj Cepl 2007-10-25 09:56:52 EDT
Oh I see, now I understand. Does it mean, that you are currently using fglrx
driver? Please, don't do that -- unless you are able to reproduce, test, etc.
only with open-source drivers, we cannot help you. Taking /var/log/Xorg.20.log
as relevant.
Comment 13 Adam Jackson 2007-10-25 10:20:13 EDT
Hmm?  If switching ALSA to OSS fixed it, then this isn't a radeon bug anyway.

Moving to kernel for triage.  I would blame pulseaudio but this is on F7 where
pulse isn't present by default.
Comment 14 Eliran Itzhak 2007-10-25 15:17:58 EDT
Please note - I've tried several things, but the problem does NOT go away.
I have the same problem in Kernel &
I have the same problem with  OSS or ALSA in the kplayer config screen
(restarted kplayer)
I have the same problem in VLC, kplayer & mplayer.
I have the same problem with .mpg & .avi files.
I have the same problem with the ATI driver from the Livna repo & the free
"radeon" driver.
Tested all these, and I keep having this problem.
Please note, when the frame rate drops to 0 and the movie stops, pressing
"pause" and then "play" in kplayer solves the problem, until the next time,
which happens again in 2 seconds to few minutes.
IF there is anything else you want me to try, I'm here.
Comment 15 Chuck Ebbert 2007-10-25 15:21:42 EDT
Maybe the tickless kernel is causing this. Try booting with kernel option
"nohz=off".  I'd say this is an application problem.
Comment 16 Eliran Itzhak 2007-10-25 19:21:53 EDT
Booted with nohz=off, and the problem persists.
Comment 17 Eliran Itzhak 2007-10-31 10:14:03 EDT
I have the same problem with both and
I have the same problem playing an audio stream and a video (avi/mpg)
I have the same problem with kplayer set to ALSA and OSS.
I have the same problem with VLC & kplayer.
I have the same problem with nohz=off.
Comment 18 Christopher Brown 2008-01-15 21:57:31 EST

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.


I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 19 Eliran Itzhak 2008-01-16 07:07:26 EST
Hi again. I've either solved the problem or found a way around it.
This bug report can be closed, and thanks again.


Note You need to log in before you can comment on or make changes to this bug.