Bug 350221 - Umlauts are locking backspace key in TUI dialog window
Umlauts are locking backspace key in TUI dialog window
Status: CLOSED DUPLICATE of bug 249717
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
: EasyFix, Reopened
Depends On:
  Show dependency treegraph
Reported: 2007-10-24 06:08 EDT by Robert Scheck
Modified: 2008-02-01 11:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-01 11:14:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-10-24 06:08:27 EDT
Description of problem:
When typing a umlaut e.g. a "ö" in the directory field at the http setup TUI 
dialog window, backspace key will be locked. Workaround is to click on "Back"
to get a usable http setup TUI dialog window during repeating the step.

The selected language setting was English with a German keyboard. As this is a 
common setting in Germany, this has to work, because "äöü" is near the "Enter" 
key and it's likely that umlauts are pressed by mistake.

The problem was solved for Fedora 7 (as per bug #206697) but it is not fixed 
for RHEL5.

Version-Release number of selected component (if applicable):

How reproducible:
Everytime, see above.

Actual results:
Umlauts are locking backspace key in TUI dialog window.

Expected results:
No locking, normal use of backspace key to delete the umlaut.
Comment 1 David Cantrell 2007-10-25 13:38:00 EDT
Bugzilla is not an official support channel for RHEL.  If you need a fix from
Fedora included in a RHEL release, please contact your support representative
who will escalate the issue through the appropriate RHEL support channels.
Comment 2 Robert Scheck 2007-10-25 13:47:25 EDT
And? Please go and fix it for RHEL 5.1, 5.2, etc. as long as RHEL5 not reached 
the maintainence phase. Thank you.

Florian...can you please have a look to it, because it's a very annoying fix 
that can be solved easily. IIRC anaconda gets updates from one dot release to 
Comment 3 David Cantrell 2007-10-25 14:37:07 EDT
We cannot simply fix every bug that is reported through Bugzilla.  We have a
finite amount of resources for each release and we have to prioritize bugs for
RHEL as they are reported through the appropriate channels.

Since this particular bug is already fixed in Fedora, we can marked it as CLOSED
NEXTRELEASE because that fix will make it in to RHEL-6.  If you need this fix in
a RHEL-5 release, you need to contact the RHEL support services team.
Comment 4 Robert Scheck 2007-10-25 15:53:20 EDT
I don't write bug reports for fun. There already exists a service request 
containing the same since March 25, 2007 - but nobody just from Red Hat, Inc.
cares about. Is that what you meant with priorizing bugs by the appropriate 

Status  Waiting on Red Hat
Reported On  25-MAR-2007 19:20:00
Confirmation: Service Request Created: 1778658-Umlauts are locking backspace 
key in TUI dialog window
25-OCT-2007 13:59:55
Urgency changes from "4-Low" to "2-High".

Well, the time you spent for annoying me this time, you could already have used 
to backport the fix and solve this issue as expected by me. I've no problem to 
reopen this report again. Florian...any comment from you?
Comment 5 David Cantrell 2007-10-25 16:10:44 EDT
If a support ticket is open, you need to use that to get the issue escalated for
RHEL engineering.
Comment 9 Joel Andres Granados 2008-02-01 04:36:30 EST
This issue is related to newt, and has already been addressed for rhel5, see
249717 for the details of the backport.
Comment 10 Suzanne Yeghiayan 2008-02-01 11:14:58 EST

*** This bug has been marked as a duplicate of 249717 ***

Note You need to log in before you can comment on or make changes to this bug.