Bug 35053 - QA0404: pump ignores DHCP server supplied domain information.
Summary: QA0404: pump ignores DHCP server supplied domain information.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-06 16:40 UTC by Eugene Kanter
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 13:36:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eugene Kanter 2001-04-06 16:40:32 UTC
If reverse DNS fails, /etc/resolv.conf contains "search localdomain" 
despite the fact that DHCP server transmits domain record. This happends 
for both NT 4.0 and RH 6.2 based dhcp servers. I believe all pump versions 
up one in QA0404 behave this way.

To reproduce:

1. make sure that IP address supplied by DHCP server resolves to a valid 
hostname. Observe that /etc/resolv.conf contains "search validdomain" 
after system is booted.

2. remove the IP address from reverse DNS and from /etc/hosts. Observe 
that /etc/resolv.conf contains "search localdomain" or similar invalid 
record.

Comment 1 Eugene Kanter 2001-04-07 18:25:09 UTC
Seems like the problem lies in --lookup-hostname option. If specified, the 
DOMAIN send by a DHCP server gets IGNORED. Since usually both the DHCP and DNS 
servers on the network are maintained by the same organization/person the 
DOMAIN send by a DHCP server should never be ignored. The relevant code around 
line 1400 in dhcp.c should be changed.....


Comment 2 Elliot Lee 2001-09-11 22:00:03 UTC
pump deprecated in favor of dhcpcd

Comment 3 Eugene Kanter 2001-09-12 12:18:10 UTC
Has anybody verified that dhcpdcd does not exibit the same behavior?


Note You need to log in before you can comment on or make changes to this bug.