Bug 35056 - emacs and xemacs gnus fails on articles with MIME headers
emacs and xemacs gnus fails on articles with MIME headers
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-06 14:23 EDT by Michael Meissner
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 14:23:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Meissner 2001-04-06 14:23:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3-ac3 i686)


Both the emacs and xemacs in the Wolverine release fail when reading
articles that have MIME headers with the message:

	Symbol's function definition is void: mailcap-parse-mailcaps

The 7.0 version of both emacs and xemacs works correctly.

Reproducible: Always
Steps to Reproduce:
1. Select news.vmware.com as newserver.
2. go to group vmware.for-linux.configuration
3. read article 6691 by David D. Huff.
4. Please contact me if you need all of my .el files.	

Actual Results:  You get the error message about not being able to find
mail-parse-mailcaps, even if you explicitly load in the file from the gnus
directory.

Expected Results:  You should get the article instead of an error message.
Comment 1 Trond Eivind Glomsrxd 2001-04-06 14:36:09 EDT
This has been fixed, in semi-1.13.7-9 (for Emacs) and in xemacs-21.1.14-10.

The issue was the semi includes it's own mailcap file, not compatible with the
standard one. It has since been renamed.

Note You need to log in before you can comment on or make changes to this bug.