Bug 350561 - GFS2: gfs2_tool command should ignore trailing "/" on mount point path
GFS2: gfs2_tool command should ignore trailing "/" on mount point path
Status: CLOSED DUPLICATE of bug 345501
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Peterson
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 11:07 EDT by Kiersten (Kerri) Anderson
Modified: 2010-01-11 22:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 11:54:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiersten (Kerri) Anderson 2007-10-24 11:07:46 EDT
Description of problem:
gfs2_tool doesn't ignore the trailing slash on the mount point pathname. This
gives you the following results:
[root@kool gfs2]# gfs2_tool gettune /mnt/aol_tests/
gfs2_tool: unknown mountpoint /mnt/aol_tests/, no device found

Since shell filename completion will insert the "/", this will be a common error
customers will observe.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Peterson 2007-10-24 11:44:48 EDT
I already opened 345501 to fix this in a more general case.
In gfs2, the user commands pretty much all use libgfs2, and libgfs2
has a generic function check_for_gfs2() that has this bug.  Bug #345501
was opened to fix that function, and gfs2_tool should pick that up
automatically.  Okay to close this as a dup?
Comment 2 Kiersten (Kerri) Anderson 2007-10-24 11:54:34 EDT

*** This bug has been marked as a duplicate of 345501 ***

Note You need to log in before you can comment on or make changes to this bug.