Bug 350631 - compress does not warn when not compressing a file
compress does not warn when not compressing a file
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ncompress (Show other bugs)
4.2
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 11:51 EDT by Jeff Morriss
Modified: 2008-05-28 03:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 10:50:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Morriss 2007-10-24 11:51:13 EDT
Description of problem:

'compress' may decide not to compress a file (if it is too small to be
compress'd, for example).  The UNIX version warns you when this happens, the
Linux version does not.

Version-Release number of selected component (if applicable):

ncompress-4.2.4-40

How reproducible:

See below:

Steps to Reproduce:
1. echo hi > foo
2. compress foo
  
Actual results:

% compress foo
%

Expected results:

% compress foo
foo: -- file unchanged
%

(This result is what Solaris does.)

Additional info:

Not a big deal, but again it's better if the user is warned.
Comment 1 RHEL Product and Program Management 2008-02-01 14:00:18 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Ondrej Vasik 2008-05-27 10:50:25 EDT
Thanks for report and sorry for late response, but I'm new maintainer of
ncompress since yesterday.

Actually many 'compress' messages are supressed by system intentionally - and
are available only in verbose mode. That mode already does what you wish in
RHEL-4 (or at least similar thing).

%compress -v foo
foo: No compression -- foo unchanged

Therefore closing NOTABUG. Feel free to add any comments if you are not
satisfied with that explanation.
Comment 3 Jeff Morriss 2008-05-27 14:45:42 EDT
Well, OK, though I would think this (verbose) output should be the default
output to avoid confusing users.
Comment 4 Ondrej Vasik 2008-05-28 03:27:39 EDT
That could lead to another bugzilla filled (I have following experience with
such double-sided decisions from other packages). They would say that compress
is more verbose than it should be - and that is no way to suppress it . Actually
that's not true, because you can suppress -v by -q (that option is undocumented)
or by redirection of stderr to /dev/null(another dirty way). So I would suggest
you usage of alias in .bashrc for compress/uncompress with -v. As compress is
almost stable utility(with (almost) dead upstream development), I don't think
that's good idea to change default behaviour. The best way would be to add some
sentences into -v option section of compress/uncompress man page and I would
suggest that change to upstream to have it more clear for future RHEL releases.

Note You need to log in before you can comment on or make changes to this bug.