Bug 350641 - own /usr/share/aclocal
own /usr/share/aclocal
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 11:56 EDT by Patrice Dumas
Modified: 2015-03-04 20:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 11:42:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2007-10-24 11:56:27 EDT
Description of problem:

autoconf macros goes in /usr/share/aclocal, owned by the automake 
package. This is inconvenient since all the packages that ship
autoconf macros have to either own the directory or depend on 
automake. Some think that shipping an autoconf macro file means 
that the package should depend on aclocal, but in my opinion this
should be left to the packager, and not caused by a directory
ownership issue.

Still it is not really a basic filesystem directory, therefore
it is not obvious that you should accept my request...

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2008-03-18 09:18:10 EDT
Any progress?
Comment 2 Phil Knirsch 2008-03-27 11:42:59 EDT
Hi Patrice.

Sorry for answering so late.

While i agree that having automake own /usr/share/aclocal is not optimal
filesystem so far doesn't own any application specific files, so i'd rather not
start it now.

As i've seen more of those requests lately though one possibility for the future
would be to add an application related filesystem package at some point which
could contain and own those application related general directories and files.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.