Bug 35072 - fsck fails at boot time
fsck fails at boot time
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-06 17:09 EDT by Carlos Saldarriaga
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-07 14:21:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Saldarriaga 2001-04-06 17:09:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


When forcing a fsck on boot up, or when maximum count is reached and fsck 
is forced, it always fails while checking root:
exited with signal 9
and drops me to the shell.  Upon running e2fsck, no errors are found, even 
checked for bad blocks. I have a big 375M root partition and a small 
3.9M /boot on a 408M disk and it always fails around 87% completion.  
Apparently the process is being killed or timedout at that point.
Package versions are:
initscripts-5.49-1; e2fsprogs-1.18-16

Reproducible: Always
Steps to Reproduce:
1./sbin/shutdown -F -r now
2.
3.
Comment 1 Bill Nottingham 2001-04-06 17:12:30 EDT
signal 9 is sigkill, which sort of implies the kernel did it. How much
memory is in the machine?
Comment 2 Florian La Roche 2001-04-06 17:36:49 EDT
If you can reproduce this with the rescue-cd from
ftp://ftp.redhat.de/pub/rh-addons/rescue-cd/, then this
would still be a problem with current glibc/e2fsprogs.

Can you please test this out? Thanks a lot.

Comment 3 Carlos Saldarriaga 2001-04-07 13:11:34 EDT
The machine is a 486sx with 11,904KB.  I will try out the rescue-cd although 
this machine doesn't have a bootable CD, so I am not sure how to run it.  I 
have tried Tomsrtbt disk and used e2fsck on /dev/hda2 (my root) and it showed 
no error.
I will try installing this disk on a 486DX with 36M to see if it shows the 
problem and I will let you know.
Comment 4 Carlos Saldarriaga 2001-04-07 14:21:15 EDT
I decided not to swap the disk to another machine, instead installed 20Mb RAM 
and tried things out with shutdown -F.  On bootup e2fsck checked OK with no 
problems.  Changed back to 12Mb and problem came back.  It seems problem is 
memory related.
Decided to try out changing fsck options in rc.sysint.  Instead of the 
completion bar option (-C), I changed it to verbose (-V) and tried again with 
12Mb.  This time fsck checked OK without the sigkill.  Would it be the 
completion bar option is using up extra memory?
Comment 5 Florian La Roche 2001-05-08 16:45:48 EDT
Ok, so not enough RAM seems to be the problem.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.