Bug 351551 - gnome-power-manager lets the laptop die without power
gnome-power-manager lets the laptop die without power
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 19:59 EDT by Julian Sikorski
Modified: 2013-03-05 22:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 04:51:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Power chart (53.64 KB, image/png)
2007-10-26 09:18 EDT, Julian Sikorski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 505243 None None None Never

  None (edit)
Description Julian Sikorski 2007-10-24 19:59:50 EDT
Description of problem:
Although I have set gpm to hibernate when battery is critical, and it dispatches
the warning, the laptop never hibernates - power gets cut off, probably by
battery safety circuits.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.20.0-6.fc8.x86_64

How reproducible:
always

Steps to Reproduce:
1. unplug the AC cord
2. wait
  
Actual results:
laptop dies once battery is empty

Expected results:
laptop hibernates prior to that

Additional info:
If my memory serves me well, this has been working OK in Fedora 7. I took a look
at loading history, and after the warning the line got bright green (lid closed)
for a while, although lid was certainly opened. Maybe the wrong event is
dispatched? This seems quite serious regression, so setting it to blocker.
Comment 1 Will Woods 2007-10-24 21:09:57 EDT
Works fine here. In fact I just woke this laptop up from an automatic hibernate. 

There's a lot of things that can go wrong with battery charge estimates, because
the information from the hardware is frequently unreliable or just plain wrong -
see Richard's post here: 
http://hughsient.livejournal.com/17018.html

gnome-power-manager gets better at estimating battery life over time. This
laptop used to die before hibernating, but it seems much more accurate about
battery life now, and it always suspends before the battery dies. How long have
you been running rawhide on your machine?
Comment 2 Julian Sikorski 2007-10-25 01:35:01 EDT
I am running rawhide here since test3. It seems that estimates are fine, since
right before the laptop died gpm was showing 1% of power left, IMHO high time to
hibernate (or poweroff if user chooses so). Is it possible to disable profiling?
It was not present in F7 and everything was OK. Besides, the "green line issue"
seems suspicious.
Comment 3 Julian Sikorski 2007-10-25 01:49:32 EDT
For reference: this is a Toshiba Satellite A100-847 laptop, aka A105 in the USA.
Comment 4 Julian Sikorski 2007-10-26 09:18:51 EDT
Created attachment 239111 [details]
Power chart

The issue just happened again. The led was blinking warning about low power,
gpm warned the laptop was going to hibernate, but nothing happened. Take a look
at the	end of the curve - green colour (lid closed, but it was open all the
time, and the remaining capacity going up). What is more, the tip that warned
about hibernate reported 0% remaining power, which was inconsistent with what
hovering over gpm icon was saying.
Comment 5 Julian Sikorski 2007-11-15 15:11:16 EST
This still happens. Where can I find some kind of logs I could provide to fix
the issue? Or disable this whole profiling thing, which clearly does not work
for me?

Note You need to log in before you can comment on or make changes to this bug.