Bug 351601 - "yum update" fails - NetworkManager-glib-0.7.0-0.3.svn3014.fc8.x86_64.rpm not signed
"yum update" fails - NetworkManager-glib-0.7.0-0.3.svn3014.fc8.x86_64.rpm not...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 21:39 EDT by Richard Ryniker
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 22:18:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
edited console output (669 bytes, text/plain)
2007-10-27 11:13 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Richard Ryniker 2007-10-24 21:39:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a5) Gecko/20070607 Minefield/3.0a5

Description of problem:
Package NetworkManager-glib-0.7.0-0.3.svn3014.fc8.x86_64.rpm is not signed

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.yum update
2.
3.

Actual Results:
Update process aborts with the message:
Package NetworkManager-glib-0.7.0-0.3.svn3014.fc8.x86_64.rpm is not signed


Expected Results:


Additional info:
Comment 1 Warren Togami 2007-10-24 22:18:21 EDT
This is not a NetworkManager bug.

We accidentally pushed fedora-release with yum configuration requiring gpg
checks.  Turn off the fedora and fedora-updates repositories, then enable
fedora-development, and it should work again.

You can either edit the files in /etc/yum.repos.d/ or use pirut to graphically
edit it.
Comment 2 Peter H. Jones 2007-10-25 09:19:42 EDT
Here is the diff -c that worked for me, and shows exactly the change needed:

*** fedora.repo.orig    2008-10-19 17:32:23.000000000 -0400
--- fedora.repo 2007-10-25 09:01:07.000000000 -0400
***************
*** 4,10 ****
 
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
 
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
  enabled=1
! gpgcheck=1
  gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY

  [fedora-debuginfo]
--- 4,11 ----
 
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
 
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
  enabled=1
! ###gpgcheck=1
! gpgcheck=0
  gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY

  [fedora-debuginfo]
Comment 3 Peter H. Jones 2007-10-27 11:13:17 EDT
Created attachment 240491 [details]
edited console output

Shows that "file /etc/yum.repos.d/Fedora-install-media.repo is not owned by any
package", which I found surprising. Of course, the message for
/etc/yum.repos.d/fedora.repo.orig is to be expected.
Comment 4 Peter H. Jones 2007-10-27 11:16:43 EDT
Further note: Today, I tried undoing my patch before running the Package
Updater. The updating failed because the packages were not signed. I reapplied
the patch with the Updater window still open, but the update wouldn't work until
I Quit and restarted the Updater. In other words, the Updater doesn't seem to
re-read the configuration files when clicking Apply Updates.

I presume this patch will become unnecessary when fedora-release-8-2 is updated,
as shown in the console log attachment.

Note You need to log in before you can comment on or make changes to this bug.