Bug 3518 - Installer mkswaps all partitions the same size
Installer mkswaps all partitions the same size
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-16 20:34 EDT by cadams
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 18:09:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cadams 1999-06-16 20:34:24 EDT
I have an existing system that I did a clean install on (I
didn't repartition the drives, but I did mke2fs them).  I
have a swap partition on both drives.  The swap partition on
the first drive is 50M and the one on the seconds drive is
90M.  It looks like the installer ran "mkswap" with the same
size on both swap partitions, because after installation and
reboot, I have 100M of swap (looking at /proc/swaps there
are two entries of 50M).

I don't know what would happen if I tried to install and the
first swap partition was bigger than the second; it looks
like it could overwrite stuff past the second partition.
Comment 1 David Lawrence 1999-07-06 16:07:59 EDT
I have verfiied this to be a problem with a standard 6.0 install.
Comment 2 Jay Turner 1999-07-07 13:07:59 EDT
*** Bug 3761 has been marked as a duplicate of this bug. ***

I was doing a fresh install on a machine
with a bit exotic setup:

/dev/hda1             1        32    257008+   6  FAT16
/dev/hda2   *        33       163   1052257+  83  Linux
/dev/hda3           164       527   2923830    5  Extended
/dev/hda5           164       172     72261   82  Linux swap
/dev/hda6           173       368   1574338+  83  Linux
/dev/hda7           369       527   1277136    7  HPFS/NTFS

/dev/hdc3             1       508    512032+   7  HPFS/NTFS
/dev/hdc4           509       827    321552    5  Extended
/dev/hdc5           509       574     66496+  82  Linux swap
/dev/hdc6           575       827    254992+  83  Linux


The hda6 is an old copy of Linux. I was installing
RH 6.0 on /dev/hda2 with swap space on /dev/hda5
and /dev/hdc5. The setup has detected both
swap partitions and I let it to reinitialise
them. Being curious as always I watched
the log messages on the other virtual screen.
To my horror I noticed that the size of the
both swaps was exact the same, corresponding
to the /dev/hda5 :-(

I verified the situation and corrected it
manually, but if unnoticed, this could
lead to severe problems.


------- Additional Comments From jturner@redhat.com  06/28/99 09:22 -------
Verified in test lab.  Created 72M and 56M swap partitions, and the
log messages showed that the installer was creating two 72M
partitions.  Completed installation and rebooted to find the
following: "free" shows 144+M of swap space available to the system;
fdisk shows a 72M and a 56M swap partition with 8 sectors and 6
sectors in use.  Pretty strange!
Comment 3 Jay Turner 2000-02-17 18:09:59 EST
This issus is resolved in the next cut of the installer.

Note You need to log in before you can comment on or make changes to this bug.