Bug 351841 - RFE: R without X dependencies
RFE: R without X dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 03:00 EDT by Rasmus Ory Nielsen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.0-3.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 17:20:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rasmus Ory Nielsen 2007-10-25 03:00:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); da-DK; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8

Description of problem:
I maintain a cluster of computing nodes. They have no X installed. I would love to see a version of R in Fedora compiled with the '--with-x=no' option.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. yum install R
2.
3.

Actual Results:
R pulls a lot of graphical dependencies, e.g. firefox, evince.

Expected Results:
R installed without grapical dependencies.

Additional info:
Comment 1 Tom "spot" Callaway 2007-10-25 09:42:31 EDT
Well, the --with-x=no would really only eliminate the dependencies on:

libSM.so.6()(64bit)  
libX11.so.6()(64bit)  
libXmu.so.6()(64bit)  
libXt.so.6()(64bit)  

Thanks to modular X, those dependencies are really small.

But what you're really noting is that we're hardcoding a Requires for evince and
firefox, because we need to define R_PDFVIEWER and R_BROWSER for the R build.

We could make an alternate R package that sets R_BROWSER to links, but I'm not
sure what non-graphical PDF viewer we could set for R_PDFVIEWER. I suppose we
could leave it entirely unset.

Let me poke this for a bit and see what I can come up with.
Comment 2 Rasmus Ory Nielsen 2007-10-25 11:25:46 EDT
Thanks for the quick reply. This sounds absolutely great. I'm looking forward to
see what you come up with.

Thanks.
Comment 3 Ville Skyttä 2007-10-28 08:33:48 EDT
Here's a patch that uses xdg-open instead of hardwired firefox and evince:
http://scop.fedorapeople.org/patches/xdg-utils/R.patch
Comment 4 Rasmus Ory Nielsen 2007-10-30 05:01:13 EDT
Hi Ville,

The link to your patch returns a '404 - Page could not be found'.

Thanks,
Rasmus
Comment 5 Ville Skyttä 2007-10-30 14:17:40 EDT
Yes, I removed the file after I saw it was applied to CVS as part of
http://cvs.fedora.redhat.com/viewcvs/devel/R/R.spec?r1=1.30&r2=1.31&makepatch=1&diff_format=h
Comment 6 Fedora Update System 2007-11-01 17:20:50 EDT
R-2.6.0-3.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Rasmus Ory Nielsen 2007-11-06 08:20:35 EST
Excellent! It works great.
I am really amazed how quick this got fixed.
Thanks!!

Note You need to log in before you can comment on or make changes to this bug.