Bug 351871 - glxinfo does not report multisample capable visuals correctly
glxinfo does not report multisample capable visuals correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 03:40 EDT by Scott A. Friedman
Modified: 2008-01-22 14:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 14:57:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott A. Friedman 2007-10-25 03:40:31 EDT
Description of problem:
glxinfo does not report multisample capable visuals because of a logic error in
the code.

Version-Release number of selected component (if applicable):
MesaDemos-6.5.2

How reproducible:
Just use glxinfo with a video card that supports multisampling (nvidia)

Steps to Reproduce:
1. glxinfo
2.
3.
  
Actual results:
always shows number of samples and number of buffers as zero

Expected results:
should show the correct values

Additional info:
Basically, the following line in the code:

   if (ext && strstr(ext, "GLX_ARB_multisample") ) == 0) {

might be changed to:

   if (ext && strstr(ext, "GLX_ARB_multisample") ) {

The code is checking for the opposite of what is desired.


Basically,
Comment 1 Adam Jackson 2008-01-22 14:57:49 EST
Fixed in upstream, will get pulled magically into F9.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.