Bug 352011 - usernames > 8 chars in "setting allowed users" by lpadmin: problem!
usernames > 8 chars in "setting allowed users" by lpadmin: problem!
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 06:29 EDT by Joachim Backes
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-26 08:03:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2007-10-25 06:29:51 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1./usr/sbin/lpadmin -p <printer> -u allow:administrator
2.
3.
  
Actual results:
Other users of printer(s) have problems so that the applications using printers
(staroffice/openoffice/firefox...) get no more a printer list, so no more print
is possible.

A command "lpq -P printer" complains  with: "lpq: Unknown destination ..."


Expected results:
The apps get a printer list

Additional info:Modifying "administrator" to "administ" is a workaround.
Comment 1 Tim Waugh 2007-10-26 07:28:42 EDT
When setting the list of allowed users to 'administrator', only the user
'administrator' can perform operations on that printer (such as viewing its job
list, printing a job, cancelling a job etc).

It does not show up in the job list for users other than 'administrator' by design.

If your user is named 'administ' then that's what you need to put in the allowed
users list. (FWIW, 'administrator' works as designed here with a local user
'administrator'.)
Comment 2 Joachim Backes 2007-10-26 07:39:14 EDT
If the list of allowed users consists only of the one entry "administrator", i
understand that nobody else can use the printer, but: 

Seems you misunderstood me: the same happens if the list of allowed users is
__ending__ with administrator, for example:

 /usr/sbin/lpadmin -p <printer> -u allow:user1,user2,...,administrator

Then none of the users user1, user2,... can print to the printer.



Comment 3 Tim Waugh 2007-10-26 08:03:03 EDT
Works here.

cups-1.2.12-5.fc7

Note You need to log in before you can comment on or make changes to this bug.