Bug 35233 - Linux doesn't boot on Topline laptop
Linux doesn't boot on Topline laptop
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-08 14:10 EDT by Ron Hollander
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron Hollander 2001-04-08 14:10:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)


I have troubles booting Linux after installing Redhat Linux 7.0 on my 
laptop (a Topline Insignis 8500 Pro).

Reproducible: Always
Steps to Reproduce:
1. Choose Linux in Lilo boot manager.
2. 
3.
	

Actual Results:  Loading Linux...
Uncompressing Linux...
crc error
-system halted

or

Loading Linux...
Uncompressing Linux...
invalid compressed format (err=2)
--system halted

or even

Loading Linux...
Uncompressing Linux...
out of memory
--system halted

or sometimes it's just

Loading Linux...

Expected Results:  Starting Linux.

My partition table looks as follows:

hda1	2996M	Win95 FAT32
hda2	2463M	Linux Native
hda3	 243M	Linux Swap
hda5	5004M	Win95 FAT32
hda6	 800M	Win95 FAT32

My harddisk has more than 1024 cylinders. hda4 is an extended partition 
with logical partitions in it (hda5,hda6).

My boot manager is installed in the master boot record. I've tried 
installing the bootmanager in hda2, I've tried the lineair and lba32 
options. They all give the same results mentioned above. What might this 
possibly be? I had the same problem when I installed Redhat Linux 6.2 in 
the past.

Booting Windows Millennium with the Lilo Boot manager works.
Comment 1 Jeremy Katz 2002-06-04 02:24:18 EDT
crc errors generally imply an error reading the kernel from the disk?  Have you
checked your disk for any errors with badblocks during the install process?
Comment 2 Jeremy Katz 2002-06-29 17:47:18 EDT
Closing due to inactivity.  If you have further information, please reopen this bug.
Comment 3 Ron Hollander 2002-07-03 06:33:32 EDT
I've solved the problem by installing MS-Dos for Windows ME, editing the 
config.sys file by adding a menu item for Linux. I boot the Linux kernel from 
my Windows ME partition by using Loadlin. That does work.
Comment 4 Red Hat Bugzilla 2006-02-21 13:47:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.