Bug 352351 - French msg translation error
French msg translation error
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 10:09 EDT by Th0ma7
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 03:42:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated french translations.... (37.06 KB, text/plain)
2007-11-07 22:36 EST, Th0ma7
no flags Details

  None (edit)
Description Th0ma7 2007-10-25 10:09:46 EDT
When installing new packages using the interface in french it displays:
10:04:30 : ---> Paquet libmad.x86_64 0:0.15.1b-5.lvn8 placé pour être updated
instead of:
10:04:30 : ---> Paquet libmad.x86_64 0:0.15.1b-5.lvn8 placé pour être mis à jour

So actually there seems to be a missing rule in the fr.po file to switch:
updated -­> mise à jour

Regards,

- vin
Comment 1 Th0ma7 2007-10-25 10:12:23 EDT
actually, more that I think about it, since that package was being installed for
the first time on my system it should have been stated "installed" instead of
"updated" in english hence "installé" instead of an eventual "mis à jour" in
french...

This case might simply not be handled yet :)

Again, regards,

- vin
Comment 2 Tim Lauridsen 2007-10-26 05:18:35 EDT
Please get the fr.po & fix it please.

http://repo.or.cz/w/yumex.git?a=blob_plain;f=po/fr.po;hb=master

Then i will add it in the next release
Comment 3 Tim Lauridsen 2007-10-26 05:29:45 EDT
Ok, look like there was some strings there was not translable, it is fixed now
but please look a the po file to see something is not looking right.
Comment 4 Th0ma7 2007-11-07 21:19:17 EST
Here are my comments.. patch to follow...

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
#: ../src/callbacks.py:184
#, fuzzy, python-format
msgid "Erased: %s"
msgstr "Effacé"

==> Missing : %s in FR.

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
==> All of theses are starting with a capital letter and probably should not...

#: ../src/callbacks.py:234
#, fuzzy
msgid "installed"
msgstr "Installé"

#: ../src/callbacks.py:235
#, fuzzy
msgid "updated"
msgstr "Mis à jour"

#: ../src/callbacks.py:236
#, fuzzy
msgid "obsoleted"
msgstr "Démodé"

#: ../src/callbacks.py:237
#, fuzzy
msgid "erased"
msgstr "Effacé"

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
==> Well, in french canadian it is a lot more associated with fashion and not
obsolescence of something... and obsolète (equivalent) do exists in french... 
At the verry least, the capital letter is probably not needed?

#: ../src/callbacks.py:236
#, fuzzy
msgid "obsoleted"
msgstr "Démodé"

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
==> Again, capitals in here..

#: ../src/callbacks.py:237
#, fuzzy
msgid "erased"
msgstr "Effacé"

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
==> "Prendre compte" is a bit more like taking your opinion then deciding to go
this way...  "prise en charge" is conceptually "taking the pile of jobs and
executing them..."

#: ../src/callbacks.py:251
msgid "--> Restarting Dependency Resolution with new changes."
msgstr ""
"--> Redémarrage de la résolution des dépendances prenant en compte les "
"nouveaux changements."

"--> Redémarrage de la résolution des dépendances avec prise en charge des "
"nouveaux changements."
Comment 5 Th0ma7 2007-11-07 21:25:57 EST
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
==> Missing ":" in the french sentence...

#: ../src/callbacks.py:259
#, python-format
msgid "--> Processing Dependency: %s for package: %s"
msgstr "--> Traitement des dépendances: %s pour le paquet %s"

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
==> shorter and more precise to say "%s conflictuel avec %s" = "%s conflicts
with" instead of "%s est en conflit avec %s" = "%s is cinflicting with %s"

#: ../src/callbacks.py:268
#, python-format
msgid "--> Processing Conflict: %s conflicts %s"
msgstr "--> Traitement des conflits: %s est en conflit avec %s"


wew.. there are alot of theses small enhancements....  I'll just send the
modified file...

- vin
Comment 6 Th0ma7 2007-11-07 21:42:37 EST
this one I'm not sure of .. I would the context (screen shot of some sort..
msgid "Package View"
msgstr "Paquet"
Comment 7 Th0ma7 2007-11-07 22:18:50 EST
This one also...
msgid "No packages in transaction"
Comment 8 Th0ma7 2007-11-07 22:36:41 EST
Created attachment 251151 [details]
Updated french translations....

Here is the updated french translation file... I hope I did it right?

I've stopped at line 999 since in kate everything else what grayed out probably
because it commented (or at least starting with #).

Took way more time that I tought... Anyhow, Hope this helps.
Comment 9 Tim Lauridsen 2007-11-08 03:42:17 EST
Thanks, i have add your translation upstream, it will be available in next yumex
release

Note You need to log in before you can comment on or make changes to this bug.