Bug 352491 - "gdmflexiserver -n" doesn't work
Summary: "gdmflexiserver -n" doesn't work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-25 15:18 UTC by Jeff Needle
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 05:19:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Needle 2007-10-25 15:18:10 UTC
Description of problem:

gdmflexiserver -n just gives me an error, "The nested X server is not available,
or GDM is badly configured. Please install the Xnest package in order to use the
nested login."

$ gdmflexiserver -dd -n

gdmflexiserver[2941]: DEBUG: Sending command: 'VERSION'

gdmflexiserver[2941]: DEBUG:   Got response: 'GDM 2.19.8'

gdmflexiserver[2941]: DEBUG: Sending command: 'AUTH_LOCAL
d83922225c358cec8790f8c411c583f4'

gdmflexiserver[2941]: DEBUG:   Got response: 'OK'

gdmflexiserver[2941]: DEBUG: Sending command: 'FLEXI_XNEST :0 3276
d83922225c358cec8790f8c411c583f4 /tmp/.gdmTLOZYT'

gdmflexiserver[2941]: DEBUG:   Got response: 'ERROR 6 No server binary'

gdmflexiserver[2941]: DEBUG: Sending command: 'CLOSE'



Version-Release number of selected component (if applicable):

$ rpm -qf `which Xnest`

xorg-x11-server-Xnest-1.3.0.0-33.fc8.i386



How reproducible:
Happens on 2 i386 rawhide machines 100% of the time.  gdmflexiserver without the
-n works as expected.  Disabling SELinux doesn't have any effect.

Comment 1 Ray Strode [halfline] 2007-10-25 16:15:20 UTC
does 

yum install /usr/bin/Xephyr

fix things?

Comment 2 Jeff Needle 2007-10-25 16:29:38 UTC
No, same behavior.

Comment 3 Matthias Clasen 2007-10-25 18:19:10 UTC
Could that be because of 

Xnest=

in /usr/share/gdm/defaults.conf ?

Comment 4 Jeff Needle 2007-10-25 18:32:53 UTC
Tried setting that to both Xephyr and Xnest (both of which are installed) and it
didn't make a difference.

Comment 5 Matthias Clasen 2007-10-25 23:45:10 UTC
I set it to 

Xnest=/usr/bin/Xnest -audit 0 -name Xnest

and now it started to work

Comment 6 Jeff Needle 2007-10-26 00:21:14 UTC
Argh.  Yeah, that works.  /usr/X11/bin/Xnest doesn't.  Because it doesn't exist.
 Which is why setting it to that isn't a useful test.

So, defaults.conf needs a tweak.  Easy enough.

Comment 7 Matthias Clasen 2007-10-26 00:56:58 UTC
defaults.conf is untouchable. Edit /etc/gdm/custom.conf instead.
The only one who can touch defaults.conf is Ray. 
Ray - do we want to set the Xnest command in defaults.conf ?

Comment 8 Ray Strode [halfline] 2007-10-26 06:07:05 UTC
actually gdm has no ACL on it.  Anyone can touch defaults.conf.

I can do it though.  Makes a lot of sense to fix this before F8.

Comment 9 Matthias Clasen 2007-11-05 05:19:08 UTC
It appears that we are setting Xnest in defaults.conf now


Note You need to log in before you can comment on or make changes to this bug.